Bug 68148 - ksconfig partition error filling all unused space on disk
Summary: ksconfig partition error filling all unused space on disk
Status: CLOSED DUPLICATE of bug 69169
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: ksconfig (Show other bugs)
(Show other bugs)
Version: limbo
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 67217
TreeView+ depends on / blocked
 
Reported: 2002-07-07 00:07 UTC by Andrew Parker
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-08 05:45:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Andrew Parker 2002-07-07 00:07:08 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020408

Description of problem:
Under some circumstances, creating a partition that 'Fills all unused space on
disk' produces an error message 'You must specify a size for this partition'. 
Also, the error message does not go away when you click ok.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  ksconfig
2.  Click partition information on left hand side
3.  Add /boot partition with 75M
4.  Add swap with 512M
5.  Add / with fill all unused space on disk
	

Actual Results:  One of two things happen here:  I either get a dialog box with
'You must specify a size for the partition' (which does not go away when you
click OK).  Sometimes I get a stack dump:

Traceback (most recent call last):
  File "/usr/share/ksconfig/ksconfig_gui.py", line 228, in on_activate_save_options
    list = self.getAllData()
  File "/usr/share/ksconfig/ksconfig_gui.py", line 205, in getAllData
    list = list + self.partition_class.getData()
  File "/usr/share/ksconfig/partition.py", line 136, in getData
    part_object = self.part_store.get_value(iter, 4)
TypeError: iter must be a GtkTreeIter


Expected Results:  Should not get either the dialog box or the stack dump

Additional info:

Comment 1 Tammy Fox 2002-07-19 02:12:52 UTC
This should be fixed in version 2.3.1-1. Marking as dup of bug with same traceback.

*** This bug has been marked as a duplicate of 69169 ***


Note You need to log in before you can comment on or make changes to this bug.