Bug 681649 - logrotate.status should not reside in /var/lib
logrotate.status should not reside in /var/lib
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: logrotate (Show other bugs)
1
Unspecified Linux
unspecified Severity low
: ---
: ---
Assigned To: Jan Kaluža
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-02 15:25 EST by William L. Thomson Jr.
Modified: 2013-05-29 05:53 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-29 05:53:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
statefile patch (257 bytes, patch)
2011-03-03 16:04 EST, William L. Thomson Jr.
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Gentoo 357275 None None None Never

  None (edit)
Description William L. Thomson Jr. 2011-03-02 15:25:22 EST
logrotate uses a logrotate.status file that is created in /var/lib. Per FHS 2.3 that should exist in a subdir, if not one specific to logrotate, then /var/lib/misc.

http://www.pathname.com/fhs/pub/fhs-2.3.html#VARLIBVARIABLESTATEINFORMATION

An application (or a group of inter-related applications) must use a subdirectory of /var/lib for its data. There is one required subdirectory, /var/lib/misc, which is intended for state files that don't need a subdirectory; the other subdirectories should only be present if the application in question is included in the distribution. [38]

[38] An important difference between this version of this standard and previous ones is that applications are now required to use a subdirectory of /var/lib. 


This causes problems on diskless systems with a shared /var/lib. Subdirs that contain unique per system data are not shared, and instead mounted on top of the shared /var/lib. I could do the same thing even for a single file, logrotate.status in this case. However given FHS, it should be written in a subdir. Which I can then make that unique per system, like other subdirs in /var/lib that are not shared amongst all diskless systems.
Comment 1 William L. Thomson Jr. 2011-03-03 16:04:01 EST
Created attachment 482158 [details]
statefile patch
Comment 2 Jan Kaluža 2011-03-07 05:18:27 EST
Thanks for the patch. That's only first part I think. I think we will have to change spec file to migrate old logrotate.conf to the new location too. I will try to do it soon and push it into rawhide for testing.
Comment 3 William L. Thomson Jr. 2011-03-08 18:54:47 EST
You are welcome, and I kinda figured it was a partial minor patch. Just figured I would provide something, more than just a bug report. Not so concerned with seeing it in any RH release, more in the next version/release of logrotate package. Wasn't sure how to report bugs directly against that project and seemed this was the best means. This is mostly pertaining to a downstream bug/issue, adding that to this bug.
Comment 4 Jan Kaluža 2011-03-09 03:26:58 EST
Ah, I understand it now :). I though you filled it against Fedora as Fedora user.
Comment 5 William L. Thomson Jr. 2011-03-09 13:13:01 EST
Yes sorry I did not mean to mislead. I wanted to file a new ticket in trac,  https://fedorahosted.org/logrotate/. But there was no easy way to do that so it seems. I followed a trail and someone in a irc channel that managed fedorahosted suggested I file a bug here, so I did. It doesn't help that I used my personal email address. I have been waiting to rejoin gentoo as a developer again. Which will be taking place here in less than an hour, hopefully. I was mostly wanting to see it address in the next release of logrotate :)
Comment 6 Jan Kaluža 2013-05-29 05:53:21 EDT
I have created ticket on trac for this issue and I will probably fix it in upcoming upstream release. Since this bug is not against Fedora itself, but against logrotate upstream project, I'm closing this bugzilla.

https://fedorahosted.org/logrotate/ticket/29

Note You need to log in before you can comment on or make changes to this bug.