Bug 68202 - Cannot Compile NVIDIA V1.0-2960 kernel driver
Cannot Compile NVIDIA V1.0-2960 kernel driver
Status: CLOSED NOTABUG
Product: Red Hat Public Beta
Classification: Retired
Component: kernel (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-07 21:46 EDT by Need Real Name
Modified: 2007-04-18 12:43 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-07 21:46:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-07-07 21:46:07 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020625

Description of problem:
The Nvidia Kernel Driver for V1.0-2960 will note compile under the Limbo Beta,
it compiled without problem under RH 7.3 2.4.18-5

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Download the NVIDIA V.10-2960 Kernel Source form the NVIDIA
website,http://www.nvidia.com/view.asp?PAGE=linux 
2. get the NVIDIA_kernel-1.0-2960.tar.gz file
3. untar the file
4. type make
5. does not complete
	

Actual Results:  The make stops with errors, the last page of display:

nv.c: In function `nv_kern_read_agpinfo':
nv.c:2071: dereferencing pointer to incomplete type
nv.c:2075: dereferencing pointer to incomplete type
nv.c:2084: warning: passing arg 1 of `nvos_find_agp_capability' from
incompatible pointer type
nv.c: In function `nv_kern_read_status':
nv.c:2121: warning: passing arg 1 of `nvos_find_agp_capability' from
incompatible pointer type
nv.c:2129: warning: passing arg 1 of `nvos_find_agp_capability' from
incompatible pointer type
nv.c: In function `nv_vtop':
nv.c:2202: warning: implicit declaration of function `put_user'
nv.c: In function `nv_find_kernel_mapping':
nv.c:2222: dereferencing pointer to incomplete type
nv.c:2224: warning: return makes pointer from integer without a cast
nv.c: In function `nv_get_phys_address':
nv.c:2240: `pgd_t' undeclared (first use in this function)
nv.c:2240: `pg_dir' undeclared (first use in this function)
nv.c:2241: `pmd_t' undeclared (first use in this function)
nv.c:2241: `pg_mid_dir' undeclared (first use in this function)
nv.c:2242: `pte_t' undeclared (first use in this function)
nv.c:2242: `pte__' undeclared (first use in this function)
nv.c:2242: `pte' undeclared (first use in this function)
nv.c:2242: warning: left-hand operand of comma expression has no effect
nv.c:2245: `high_memory' undeclared (first use in this function)
nv.c:2255: `PAGE_OFFSET' undeclared (first use in this function)
nv.c:2256: warning: implicit declaration of function `__pa'
nv.c:2259: `init_mm' undeclared (first use in this function)
nv.c:2261: `current' undeclared (first use in this function)
nv.c:2267: warning: implicit declaration of function `pmd_val'
nv.c:2276: parse error before ')' token
nv.c:2282: warning: implicit declaration of function `pte_val'
nv.c: In function `nv_alloc_pages':
nv.c:2321: `GFP_KERNEL' undeclared (first use in this function)
nv.c:2330: `current' undeclared (first use in this function)
nv.c:2356: `PG_reserved' undeclared (first use in this function)
nv.c:2356: invalid type argument of `->'
nv.c: In function `nv_free_pages':
nv.c:2495: `PG_reserved' undeclared (first use in this function)
nv.c:2495: invalid type argument of `->'
nv.c:2500: warning: implicit declaration of function `free_pages'
nv.c: In function `nv_post_event':
nv.c:2852: dereferencing pointer to incomplete type
nv.c:2853: dereferencing pointer to incomplete type
nv.c: In function `nv_agp_init':
nv.c:2925: warning: implicit declaration of function `inter_module_get'
nv.c:2926: warning: implicit declaration of function `inter_module_put'
/usr/include/linux/highmem.h: At top level:
nv.c:236: storage size of `nv_fops' isn't known
nv.c:1124: storage size of `nv_vm_ops' isn't known
make: *** [nv.o] Error 1


Expected Results:  The driver should compile with some warnings, and create a
NVdriver file to be installed

Additional info:
Comment 1 Bill Nottingham 2002-07-08 02:14:33 EDT
You may want to address this to nvidia; obviously their glue wrapper needs updating.
Comment 2 Anthony Spinillo 2002-07-08 17:53:50 EDT
Due to another problem (67983), I installed kernel-2.4.18-5.62
from Rawhide. I was able to compile, and install the Nvidia module.
X started fine. I did not get around to test any 3D apps.
I did not try to compile with the original Limbo stock kernel.

Note You need to log in before you can comment on or make changes to this bug.