Bug 68239 - DCOP problem with different sessions
DCOP problem with different sessions
Status: CLOSED CANTFIX
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Petr Rockai
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-08 10:47 EDT by Michael Redinger
Modified: 2007-04-18 12:43 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 14:19:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Redinger 2002-07-08 10:47:41 EDT
(I think this problem has been there for quite some time ...)

When being logged in twice in KDE (once locally, once using eg. Exceed), DCOP
doesn't work reliably. You can't eg. start konqueror anymore, the error shown
below is given.

How to reproduce:

1. Log into KDE (using kdm)
2. Connect via XDMCP (eg. Exceed) to your Linux box and log in
3. Now start konsole and enter konqueror. The close konqueror
4. Repeat this on the other host. IF still successful, repeat on the first etc.
   For me, the error occurs after starting konqueror 2 or 3 times.


Error message:
[c102mr@red2-c102 c102mr]$ konqueror
Session management error: Could not open network socket
DCOPClient::attachInternal. Attach failed Could not open network socket
kdeinit: Shutting down running client.
---------------------------------
It looks like dcopserver is already running. If you are sure
that it is not already running, remove
/home/c102mr/.DCOPserver_red2-c102.uibk.ac.at__0
and start dcopserver again.
---------------------------------

DCOPClient::attachInternal. Attach failed Could not open network socket
DCOPClient::attachInternal. Attach failed Could not open network socket
kdeinit: Communication error with launcher. Exiting!
DCOPClient::attachInternal. Attach failed Could not open network socket
DCOPClient::attachInternal. Attach failed Could not open network socket
DCOPClient::attachInternal. Attach failed Could not open network socket
DCOPClient::attachInternal. Attach failed Could not open network socket
DCOPClient::attachInternal. Attach failed Could not open network socket
DCOPClient::attachInternal. Attach failed Could not open network socket




Then the a GUI dialog is shown:

DCOP communications error (Konsole)
There was an error setting up inter-process
communications for KDE. The message returned
by the system was:

Could not open network socket

Please check that the "dcopserver" program is running!




Well, dcopserver is still running (once for each session).
Comment 1 Petr Rockai 2006-07-17 14:15:32 EDT
This bug is reported against old release of Red Hat Linux or Fedora Core 
that is no longer supported. Chances are that it has been already fixed in 
newer Fedora Core release. If you still experience the problem with 
current release of Fedora Core, please update the Version field (you may 
need to switch Product to Fedora Core first) in the bug report and put it 
back to NEW state.
Comment 2 Bill Nottingham 2006-10-18 14:19:58 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
If this issue is still present in a current Fedora Core release, please
open a new bug with the relevant information.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.