Bug 68247 - KPackage crash on component uninstall(Easily reproducible)
KPackage crash on component uninstall(Easily reproducible)
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kpackage (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-08 12:02 EDT by Need Real Name
Modified: 2007-04-18 12:43 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-19 23:55:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Sample Crash Handler Output (3.63 KB, text/plain)
2003-02-02 23:44 EST, Robert Lightfoot
no flags Details
Another Crash Handler Sample (3.63 KB, text/plain)
2003-02-02 23:49 EST, Robert Lightfoot
no flags Details
Yet Another Crash Handler Error (3.63 KB, text/plain)
2003-02-02 23:53 EST, Robert Lightfoot
no flags Details
One Last Crash handler Sample Output (3.64 KB, text/plain)
2003-02-02 23:56 EST, Robert Lightfoot
no flags Details

  None (edit)
Description Need Real Name 2002-07-08 12:02:07 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.79 [en] (X11; U; Linux 2.4.18-3 i686)

Description of problem:
The crash is seen when trying to uninstall "XFree86-devel".
Looks like this happens for every uninstall.  Tried to reproduce
by trying to uninstall "qt-devel",  again it crashed.

How to reproduce:
1. start Kpackage
2. Select a package to uninstall
3. click "Uninstall"
4. Get a crash


The following is the crash info provided by CrashHandler:


 (no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...[New Thread 1024
(LWP 1434)]

0x420b4769 in times () from /lib/i686/libc.so.6
#0  0x420b4769 in times () from /lib/i686/libc.so.6
#1  0x4213030c in __DTOR_END__ () from /lib/i686/libc.so.6
#2  0x40f4fca3 in waitpid () from /lib/i686/libpthread.so.0
#3  0x4062b8d2 in KCrash::defaultCrashHandler ()
   from /usr/lib/libkdecore-gcc2.96.so.4
#4  0x40f4df75 in pthread_sighandler () from /lib/i686/libpthread.so.0
#5  0x42029098 in ssignal () from /lib/i686/libc.so.6
#6  0x420551d8 in group_number () from /lib/i686/libc.so.6
#7  0x42050347 in _i18n_number_rewrite () from /lib/i686/libc.so.6
#8  0x4205a197 in printf_size () from /lib/i686/libc.so.6
#9  0x080a29d5 in KprintDepProblems ()
#10 0x080a22c4 in doUninstal ()
#11 0x08092193 in RPM::doUninst ()
#12 0x08091951 in RPM::uninstall ()
#13 0x080742d0 in pkgOptionsU::doPackages ()
#14 0x08073c41 in pkgOptions::pkginstallButtonClicked ()
#15 0x080744cd in pkgOptions::qt_invoke ()
#16 0x40938ec7 in QObject::activate_signal ()
   from /usr/lib/qt3-gcc2.96/lib/libqt-mt.so.3
#17 0x40938e28 in QObject::activate_signal ()
   from /usr/lib/qt3-gcc2.96/lib/libqt-mt.so.3
#18 0x40c39a58 in QButton::clicked ()
   from /usr/lib/qt3-gcc2.96/lib/libqt-mt.so.3
#19 0x409cda57 in QButton::mouseReleaseEvent ()
   from /usr/lib/qt3-gcc2.96/lib/libqt-mt.so.3
#20 0x40969000 in QWidget::event () from /usr/lib/qt3-gcc2.96/lib/libqt-mt.so.3
#21 0x408d8ff3 in QApplication::internalNotify ()
   from /usr/lib/qt3-gcc2.96/lib/libqt-mt.so.3
#22 0x408d8723 in QApplication::notify ()
   from /usr/lib/qt3-gcc2.96/lib/libqt-mt.so.3
#23 0x40590f1b in KApplication::notify () from /usr/lib/libkdecore-gcc2.96.so.4
#24 0x40881871 in QETWidget::translateMouseEvent ()
   from /usr/lib/qt3-gcc2.96/lib/libqt-mt.so.3
#25 0x4087ea80 in QApplication::x11ProcessEvent ()
   from /usr/lib/qt3-gcc2.96/lib/libqt-mt.so.3
#26 0x4087d6ce in QApplication::processNextEvent ()
   from /usr/lib/qt3-gcc2.96/lib/libqt-mt.so.3
#27 0x408da4bc in QApplication::enter_loop ()
   from /usr/lib/qt3-gcc2.96/lib/libqt-mt.so.3
#28 0x40a96ade in QDialog::exec () from /usr/lib/qt3-gcc2.96/lib/libqt-mt.so.3
#29 0x08066a0d in managementWidget::uninstallMultClicked ()
#30 0x08067f41 in managementWidget::qt_invoke ()
#31 0x40938ec7 in QObject::activate_signal ()
   from /usr/lib/qt3-gcc2.96/lib/libqt-mt.so.3
#32 0x40938e28 in QObject::activate_signal ()
   from /usr/lib/qt3-gcc2.96/lib/libqt-mt.so.3
#33 0x40c39a58 in QButton::clicked ()
   from /usr/lib/qt3-gcc2.96/lib/libqt-mt.so.3
#34 0x409cda57 in QButton::mouseReleaseEvent ()
   from /usr/lib/qt3-gcc2.96/lib/libqt-mt.so.3
#35 0x40969000 in QWidget::event () from /usr/lib/qt3-gcc2.96/lib/libqt-mt.so.3
#36 0x408d8ff3 in QApplication::internalNotify ()
   from /usr/lib/qt3-gcc2.96/lib/libqt-mt.so.3
#37 0x408d8723 in QApplication::notify ()
   from /usr/lib/qt3-gcc2.96/lib/libqt-mt.so.3
#38 0x40590f1b in KApplication::notify () from /usr/lib/libkdecore-gcc2.96.so.4
#39 0x40881871 in QETWidget::translateMouseEvent ()
   from /usr/lib/qt3-gcc2.96/lib/libqt-mt.so.3
#40 0x4087ea80 in QApplication::x11ProcessEvent ()
   from /usr/lib/qt3-gcc2.96/lib/libqt-mt.so.3
#41 0x4087d6ce in QApplication::processNextEvent ()
   from /usr/lib/qt3-gcc2.96/lib/libqt-mt.so.3
#42 0x408da4bc in QApplication::enter_loop ()
   from /usr/lib/qt3-gcc2.96/lib/libqt-mt.so.3
#43 0x4087d637 in QApplication::exec ()
   from /usr/lib/qt3-gcc2.96/lib/libqt-mt.so.3
#44 0x0807a05d in main ()
#45 0x42017499 in init () from /lib/i686/libc.so.6



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. start Kpackage
2. Select a package to uninstall
3. click "Uninstall"
4. Get a crash


Actual Results:  CrashHandler shows the stacktrace of coredump

Expected Results:  Clean uninstall

Additional info:

There is one bug raised but not sure its related.
Bug number: 56358
Comment 1 Robert Lightfoot 2003-02-02 23:44:02 EST
Created attachment 89793 [details]
Sample Crash Handler Output
Comment 2 Robert Lightfoot 2003-02-02 23:49:43 EST
Created attachment 89794 [details]
Another Crash Handler Sample
Comment 3 Robert Lightfoot 2003-02-02 23:53:06 EST
Created attachment 89795 [details]
Yet Another Crash Handler Error
Comment 4 Robert Lightfoot 2003-02-02 23:56:42 EST
Created attachment 89796 [details]
One Last Crash handler Sample Output

Giving up using Kpackage - Back to a reliable tool gnorpm.
Comment 5 Bill Nottingham 2003-02-19 23:55:43 EST
At this point, since we don't ship kpackage currently, we most likely will not
address these bugs.

Note You need to log in before you can comment on or make changes to this bug.