This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 682918 - URL handling broken in F15 (URLs underlined but not opened on click, no options in right-click menu)
URL handling broken in F15 (URLs underlined but not opened on click, no optio...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gnome-terminal (Show other bugs)
15
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Behdad Esfahbod
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-07 19:06 EST by Adam Williamson
Modified: 2011-03-11 14:37 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-11 14:37:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Adam Williamson 2011-03-07 19:06:50 EST
GNOME Terminal's special handling of strings recognized as URLs in the terminal seems to be broken in current F15.

To reproduce, go into a terminal and type 'http://www.google.com' . Note that if you mouse over it, an underline appears, indicating it has been recognized as a URL. However, if you click on it, it doesn't open the page in Firefox, as you'd expect (it appears to do nothing). If you right-click on it, there are no 'open link' or 'copy link address' options as there were in F14, it just shows the regular right-click menu. In addition, if you right-click on a URL and then click outside the right-click menu to exit it, the cursor will be stuck as the 'hand with pointing finger' image in that particular terminal tab (but not any other one).
Comment 1 Adam Williamson 2011-03-11 14:37:00 EST
ahaha. this is somewhat embarrassing. The described behaviour is exactly correct...for LXTerminal. Which I'd forgotten I was using because of bugs in GNOME Terminal early on in F15 cycle. =) Switched back to gnome-terminal and URL handling works as normal, I'll see if those bugs I was hitting before have gone away now.

Note You need to log in before you can comment on or make changes to this bug.