Bug 68314 - post install configuration hangs at 60%
post install configuration hangs at 60%
Status: CLOSED WORKSFORME
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
: 68501 (view as bug list)
Depends On:
Blocks: 67217
  Show dependency treegraph
 
Reported: 2002-07-08 21:59 EDT by Need Real Name
Modified: 2007-04-18 12:43 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-06 14:29:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-07-08 21:59:24 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
Regardless of what packages i choose to install or wether I install in 
graphical or text mode the install hangs at 60% of the post install 
configuration.

I rebooted from the install CD and selected rescue and looked 
at /root/install.log.

These were copied by hand so they might not be completely accurate. 

Install Info: Menu item 'wc' already exists for the file 'coreutils'
execution of %post scriplet from text-utils-2.0.21-4 failed, exit status 1

Installing rpm-4.1-0.34.
Warning cannont get exclusive lock on /var/lib/rpmPackages.

Install Info: Menu item 'yes' already exists for the file 'coreutils'
execution of %post scriplet from sh-utils-2.0-11-7 failed, exit status 1

The last item it has in the log before locking up was "Installing
isdn4k-utils-3.1-57"

I tried unchecking that package and reinstalling but it still locked up at 60%.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Perform a routine install
2.Install hangs at 60% of Post-Install Configuration
3.	

Additional info:

System: 1 Ghz, P3. 512 Megs ram, Geforce 3 with 64 Megs ram. Microsoft Natural 
Pro Keyaboad and Wireless Intellimouse. System works fine with Redhat 7.3.
Comment 1 Jeremy Katz 2002-07-08 23:11:58 EDT
60% of the post-install progress bar is the call to kudzu.
Comment 2 Bill Nottingham 2002-07-09 16:07:19 EDT
If you switch to VT2 and run ps, is kudzu running?
Comment 3 Bill Nottingham 2002-07-16 23:48:07 EDT
Not a kudzu bug.
Comment 4 Need Real Name 2002-07-16 23:58:47 EDT
I'm unable to switch terminals as the machine locks up solid with no keyboard
responce.
Comment 5 Michael Fulbright 2002-07-18 13:35:43 EDT
My experience is this happens when anaconda mounts /proc/bus/usb before running
kudzu, so its probably a kernel bug.

Any ideas on this Trond - we reproduced it on your system.
Comment 6 Michael Fulbright 2002-07-18 13:36:02 EDT
*** Bug 68501 has been marked as a duplicate of this bug. ***
Comment 7 Trond Eivind Glomsrxd 2002-07-18 14:17:08 EDT
As msf said... installing with usb devices, mouting it inside the chroot seems
to do bad things.
Comment 8 Agustin Cardenas 2002-07-23 02:30:50 EDT
I have the bug 68501 with the same problem but now I can Install this beta test in other hard 
disk. I have the same 40Gb Seagate but i recently install a 6.4Gb Quantum fireball like primary 
slave and now i can get the installation process finish but in the last screen i push the exit 
button but my machine does not reboot and i have to push the reset button and when reboot 
everything its O.K. I get the wizard to configure my machine and now I have a perfectly 
system working
Comment 9 Markku Kolkka 2002-07-31 06:28:23 EDT
The similar lockup happens to me in Limbo 2 installation, the system locks up
completely in Post install configuration. I tried it several times, both in text
and GUI mode, with different package configurations, and it always locks up in
the same place.
Comment 10 Markku Kolkka 2002-07-31 13:02:28 EDT
I reinstalled 7.3 and then upgraded to Limbo2, this worked while all attempts of
clean install locked up.
Comment 11 Michael Fulbright 2002-08-06 14:29:48 EDT
When we saw this problem back a few betas ago it occurred when anaconda was
mounting /proc/bus/usb in the chroot of the newly installed system just before
running kudzu in the post-install.  The kernel just locked hard when we did this.

We haven't been able to reproduce this issue with beta 2 again.  I'll try one
more time.
Comment 12 Michael Fulbright 2002-08-14 12:10:37 EDT
We cannot reproduce this issue with the latest kernels.

Note You need to log in before you can comment on or make changes to this bug.