Bug 68332 - menu and item isn't shown for CJK.
menu and item isn't shown for CJK.
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: redhat-config-kickstart (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
Depends On: 65866
Blocks: 67217
  Show dependency treegraph
 
Reported: 2002-07-09 04:35 EDT by Akira TAGOH
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-27 03:49:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Akira TAGOH 2002-07-09 04:35:11 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020625

Description of problem:
And more warnings are output:
(ksconfig.py:4014): Gtk-WARNING **: Invalid input string
...
** (ksconfig.py:4014): WARNING **: Invalid UTF8 string passed to
pango_layout_set_text()


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.runs ksconfig with LANG=ja_JP.eucJP for example.
2.
3.
	

Additional info:

I can see this problem with all CJK locale.
Comment 1 Brent Fox 2002-08-17 08:25:44 EDT
2.3.2-16 should fix the problem with spewing all the error messages to the
command line.  However, the CJK translations aren't showing up in the parts of
the screen that are created in glade.  

For example, the list of screens on the left is fully translated and looks nice.
 These strings are specified inside the .py files.  However, on the right side
of the screen, the translations do not appear.  These screens are done in Glade
and the strings come from the glade file.  The glade strings are translated, but
they just aren't getting pulled into the UI for some reason.  This does not
happen with European languages.

I've also noticed that CJK translations don't appear in redhat-config-users
either, which is also done in glade.  It appears that there's a problem
displaying CJK strings in glade.  I don't fully understand what the problem is.
Comment 2 Akira TAGOH 2002-08-17 20:31:24 EDT
Well, I'm not sure I can't find 2.3.2-16 on porkchop, but redhat-config-users
works for Japanese at least. some strings aren't translated, though.
Can you put 2.3.2-16 somewhere?
Comment 3 Brent Fox 2002-08-19 14:01:34 EDT
Beehive was down the other day so I couldn't build it.  I just ran it through so
it should be in dist-8.0-HEAD now.
Comment 4 Akira TAGOH 2002-08-27 03:49:40 EDT
2.3.2-16 works fine.
Comment 5 Jay Turner 2002-08-28 20:26:15 EDT
Closing out, as it looks good to me as well with 2.3.3-1.

Note You need to log in before you can comment on or make changes to this bug.