Bug 68357 - X server hangs when exiting twm.
X server hangs when exiting twm.
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: kernel (Show other bugs)
limbo
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-09 11:34 EDT by Ted Clark
Modified: 2007-04-18 12:43 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-09 11:34:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ted Clark 2002-07-09 11:34:32 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.0 (X11; Linux i686; U;) Gecko/20020408

Description of problem:
I have installed Limbo with basic X support but no Gnome or KDE libs.  When I
run startx from runlevel 3, the X server starts and loads twm, but when I select
'exit' from the twm root-window menu, the screen goes black.  Ctrl-alt-bksp does
not exit.  /var/log/XFree86.0.log contains the following errors:

(EE) GARTInit: AGPIOC_INFO failed (Invalid argument)
(EE) I810(0): AGP GART support is not available.  Make sure your kernel has
        agpgart support or that the agpgart kernel module is loaded.

[snip]

(EE) Screen(s) found, but none have a usable configuration.


The screen section in /etc/X11/XF86Config looks like:

Section "Screen"
        Identifier   "Screen0"
        Device       "Intel 815"
        Monitor      "Monitor0"
        DefaultDepth    16

        Subsection "Display"
        Depth       16
                Modes       "1280x960" "1152x864" "1024x768" "800x600" "640x480" 
        EndSubsection

EndSection


If I alt-fn to another terminal window and run startx, I get the error message
'Fatal server error: no screens found'.  I have to reboot the system to
successfully restart the X server.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install Limbo with basic X support but no Gnome or KDE libraries.
2. Run startx from runlevel 3.
3. Select 'exit' from the twm root-window menu.
	

Actual Results:  Black screen.

Expected Results:  I should be returned to a bash prompt.

Additional info:

Intel 815 graphics shipset on motherboard.
Comment 1 Bill Nottingham 2002-07-09 16:23:37 EDT
This should be fixed in kernel-2.4.18-5.63.

Note You need to log in before you can comment on or make changes to this bug.