Bug 68405 - anaconda unhandled exception when partitioning when a mix of FAT16 and FAT32 present
anaconda unhandled exception when partitioning when a mix of FAT16 and FAT32 ...
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-09 18:42 EDT by Tom Strine
Modified: 2007-04-18 12:44 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-02 16:21:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Traceback dump (24.47 KB, text/plain)
2002-07-09 19:05 EDT, Tom Strine
no flags Details

  None (edit)
Description Tom Strine 2002-07-09 18:42:13 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows 98; Win 9x 4.90)

Description of problem:
My first hard drive contains Windows ME, I want to install Linux on my second 
hard drive.
As I go into the partitioning setup, I get a message stating "The partition 
table on /tmp/hda is inconsistent. Linux may have detected the BIOS geometry 
incorrectly." It tells me i can choose to ignore the error or cancel setup, 
when I ignore the error, the next screen says "Warning: The partition table on 
device hda was unreadable." I then have the option to initialize the drive & 
loose Windows ME, naturally I select "No".
The next screen gives me an Unhandled Exception error. See results section 
below.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Enter partitioning setup
2. "Ignore" unreadabe partition table message
3. Choose not to initialize hda (and loose Win ME).


Actual Results:  Summary:

Anaconda: An unhandled exception has occured

Traceback (innermost last):
File "/usr/bin/anaconda", line 633, in ?
intf.run(id, dispatch, configFileData)
File "/usr/src/build/90289-i386/install//usr/lib/anaconda/text.py", line 427, 
in run
File "/usr/src/build/90289-i386/install//usr/lib/anaconda/dispatch.py", line 
144, in gotoNext
File "/usr/src/build/90289-i386/install//usr/lib/anaconda/dispatch.py", line 
209, in moveStep
File "/usr/src/build/90289-i386/install//usr/lib/anaconda/partitioning.py", 
line 1586, in partitionMethodSetup
File "/usr/src/build/90289-i386/install//usr/lib/anaconda/partitioning.py", 
line 1571, in setProtected
TypeError: attribute-less object (assign or del)

I have attached the full dump.

Expected Results:  I expected to be able to leave hda alone, partition hdb, 
then continue setup.

Additional info:

hda is partitioned as follows:
1.8GB primary FAT32 partition
7GB extended partition with 2 logical drives = 5.2GB FAT32 and 1.8GB FAT
Comment 1 Tom Strine 2002-07-09 19:05:12 EDT
Created attachment 64467 [details]
Traceback dump
Comment 2 Tom Strine 2002-07-09 19:07:46 EDT
By the way, I've tried running scandisk and fdisk /mbr
Comment 3 Tom Strine 2002-07-09 23:34:52 EDT
I fixed the problem.

It was caused by me having a mix of FAT32 and FAT16 partitions on hda.

once I made my 2nd logical drive FAT32 everything went fine.

Sorry for the trouble.
Comment 4 Michael Fulbright 2002-07-10 14:51:23 EDT
Still sounds like a problem - could you give us a list of the partitions and
their FAT-types when you were having a problem please?
Comment 5 Tom Strine 2002-07-10 22:21:31 EDT
hda was partitioned as follows:

1.8GB primary FAT32 partition

7GB extended partition with 2 logical drives = 5.2GB FAT32 and 1.8GB FAT16
Comment 6 Michael Fulbright 2002-08-12 17:49:35 EDT
Thank you.
Comment 7 Michael Fulbright 2002-10-03 16:46:55 EDT
I've tried to reproduce this without any success.
Comment 8 Michael Fulbright 2002-12-20 12:38:25 EST
Time tracking values updated

Note You need to log in before you can comment on or make changes to this bug.