Bug 68406 - gnome-terminal crashes while resizing window
gnome-terminal crashes while resizing window
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: vte (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Mike McLean
:
: 68608 (view as bug list)
Depends On:
Blocks: 67217 79578
  Show dependency treegraph
 
Reported: 2002-07-09 18:43 EDT by Ben Levenson
Modified: 2007-04-18 12:44 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-16 14:10:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace (483.57 KB, text/plain)
2002-07-09 18:44 EDT, Ben Levenson
no flags Details

  None (edit)
Description Ben Levenson 2002-07-09 18:43:43 EDT
Description of Problem:
resizing gnome-terminal while running 'man', 'less' or 'vim' causes a
segmentation fault.

Version-Release number of selected component (if applicable):
gnome-terminal-2.0.0-3

How Reproducible:
90%

Steps to Reproduce:
1. launch one of the apps listed above in a gnome-terminal
2. drag bottom right corner to resize 
3. eventually it will seg fault.

Additional Information:
* hasn't happened while maximizing / minimizing.
* other 'app + gnome-terminal' combos may also cause the crash, but the three
  listed above were the only ones used to reproduce this bug.
* strace to follow -- though, I'm not sure how useful it will be since it
  apparently exits with a '0'
Comment 1 Ben Levenson 2002-07-09 18:44:24 EDT
Created attachment 64466 [details]
strace
Comment 2 Havoc Pennington 2002-07-09 18:50:57 EDT
I'm guessing this is a vte issue, I could be wrong.

Doing the strace with "-f" could be more informative. But a backtrace is really
what's wanted. Don't you get the gnome crash dialog?
Comment 3 Ben Levenson 2002-07-09 18:55:39 EDT
installing gdb helps a bit. :)

Backtrace was generated from '/usr/bin/gnome-terminal'

(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...[New Thread 1024 (LWP 2918)]
0x4209ce49 in wait4 () from /lib/i686/libc.so.6
#0  0x4209ce49 in wait4 () from /lib/i686/libc.so.6
#1  0x4211422c in __DTOR_END__ () from /lib/i686/libc.so.6
#2  0x408ada43 in waitpid () from /lib/i686/libpthread.so.0
#3  0x405b1735 in libgnomeui_module_info_get () from /usr/lib/libgnomeui-2.so.0

Thread 1 (Thread 1024 (LWP 2918)):
#0  0x4209ce49 in wait4 () from /lib/i686/libc.so.6
No symbol table info available.
#1  0x4211422c in __DTOR_END__ () from /lib/i686/libc.so.6
No symbol table info available.
#2  0x408ada43 in waitpid () from /lib/i686/libpthread.so.0
No symbol table info available.
#3  0x405b1735 in libgnomeui_module_info_get () from /usr/lib/libgnomeui-2.so.0
No symbol table info available.
#0  0x4209ce49 in wait4 () from /lib/i686/libc.so.6
Comment 4 Nalin Dahyabhai 2002-07-13 00:51:39 EDT
Various line offsets in the widget could be made to hold negative values if you
resized the window, and this should be fixed in 0.4.8 and later.
Comment 5 Nalin Dahyabhai 2002-07-13 00:52:32 EDT
*** Bug 68608 has been marked as a duplicate of this bug. ***
Comment 6 Ben Levenson 2002-07-17 13:03:27 EDT
fix verified: vte-0.4.9-2
CLOSING -> RAWHIDE
Comment 7 Mike McLean 2002-12-02 11:22:42 EST
I am still seeing gnome-terminal crash on resize regularly with Red Hat 8.0:
vte-0.8.19-1
gnome-terminal-2.0.1-5
glibc-2.2.93-5

I usually have several gnome-terminal windows open with several tabs each. I
wasn't running man, less, or vim, at least not in the active terminal. 

Backtrace was generated from '/usr/bin/gnome-terminal'

(no debugging symbols found)...[New Thread 8192 (LWP 30467)]
0x420ae169 in wait4 () from /lib/i686/libc.so.6
#0  0x420ae169 in wait4 () from /lib/i686/libc.so.6
#1  0x4212a2d0 in __DTOR_END__ () from /lib/i686/libc.so.6
#2  0x408f7c63 in waitpid () from /lib/i686/libpthread.so.0
#3  0x40241ff5 in libgnomeui_module_info_get () from /usr/lib/libgnomeui-2.so.0
#4  0x408f947e in __pthread_sighandler () from /lib/i686/libpthread.so.0
#5  <signal handler called>
#6  0x42028cc1 in kill () from /lib/i686/libc.so.6
#7  0x408f607d in raise () from /lib/i686/libpthread.so.0
#8  0x4202a019 in abort () from /lib/i686/libc.so.6
#9  0x40949476 in g_logv () from /usr/lib/libglib-2.0.so.0
#10 0x409494b4 in g_log () from /usr/lib/libglib-2.0.so.0
#11 0x400425fe in vte_terminal_ensure_cursor () from /usr/lib/libvte.so.2
#12 0x40041a53 in vte_sequence_handler_ce () from /usr/lib/libvte.so.2
#13 0x4004778d in vte_terminal_handle_sequence () from /usr/lib/libvte.so.2
#14 0x4004858e in vte_terminal_process_incoming () from /usr/lib/libvte.so.2
#15 0x40943c83 in g_idle_dispatch () from /usr/lib/libglib-2.0.so.0
#16 0x40940f65 in g_main_dispatch () from /usr/lib/libglib-2.0.so.0
#17 0x40941f98 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#18 0x409422ad in g_main_context_iterate () from /usr/lib/libglib-2.0.so.0
#19 0x40942a1f in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#20 0x4044439f in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#21 0x08058256 in main ()
#22 0x420158d4 in __libc_start_main () from /lib/i686/libc.so.6

Thread 1 (Thread 8192 (LWP 30467)):
#0  0x420ae169 in wait4 () from /lib/i686/libc.so.6
No symbol table info available.
#1  0x4212a2d0 in __DTOR_END__ () from /lib/i686/libc.so.6
No symbol table info available.
#2  0x408f7c63 in waitpid () from /lib/i686/libpthread.so.0
No symbol table info available.
#3  0x40241ff5 in libgnomeui_module_info_get () from /usr/lib/libgnomeui-2.so.0
No symbol table info available.
#4  0x408f947e in __pthread_s
Comment 8 Havoc Pennington 2002-12-02 11:45:51 EST
this is a many-many-dups bug (the ensure_cursor backtrace)
already fixed in Rawhide.
Comment 9 Mike McLean 2002-12-02 14:01:53 EST
hp, did you mean to close/dup this bug then?

Also, what package in rawhide fixes this bug?
Comment 10 Matt Wilson 2003-02-16 14:10:40 EST
this is fixed in rawhide.

Note You need to log in before you can comment on or make changes to this bug.