Bug 68439 - can't get chooser from remote X terminal (gdmchooser crashes)
Summary: can't get chooser from remote X terminal (gdmchooser crashes)
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: gdm (Show other bugs)
(Show other bugs)
Version: limbo
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 67218
TreeView+ depends on / blocked
 
Reported: 2002-07-10 08:32 UTC by Pavel
Modified: 2007-04-18 16:44 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-15 20:44:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
syslog messages of failure (gdm debug output enabled) (20.25 KB, text/plain)
2002-07-10 08:33 UTC, Pavel
no flags Details
gdmchooser error output (751 bytes, text/plain)
2002-07-10 08:34 UTC, Pavel
no flags Details

Description Pavel 2002-07-10 08:32:03 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1a+) Gecko/20020709

Description of problem:
When I'm trying to connect with remote X terminal using indirect connection and
using gdm as display manager, I don't get a chooser and X just restarts. Query
connection works fine. When I run gdmchooser from command line it crashes.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Enable XDMCP for gdm and restart it.
2. Connect from other computer using "X -indirect <IP address/hostname> :<display>"

OR 
run gdmchooser from terminal

Actual Results:  X server restarts

OR 
gdmchooser crashes

Expected Results:  Get chooser window

Additional info:

Comment 1 Pavel 2002-07-10 08:33:38 UTC
Created attachment 64564 [details]
syslog messages of failure (gdm debug output enabled)

Comment 2 Pavel 2002-07-10 08:34:34 UTC
Created attachment 64565 [details]
gdmchooser error output

Comment 3 Havoc Pennington 2002-07-15 03:29:41 UTC
http://bugzilla.gnome.org/show_bug.cgi?id=88180

What is the remote terminal? (another linux machine, a real hardware X
terminal... ?)

Comment 4 Pavel 2002-07-15 06:45:31 UTC
I'm using XFree86 for cygwin on Win2k, but I also tried to connect from another
linux machine (running RedHat 7.3 with XFree 4.2.0) and StarNet X-Win32. All
give same result.

Comment 5 George Lebl 2002-07-15 20:44:40 UTC
This should be fixed in 2.4.0.1 if I remember correctly.  Several more related
bugs are fixed in CVS and so I'll make a 2.4.0.2 very very soon.

Comment 6 Elliot Lee 2002-08-26 17:34:10 UTC
Works now, I'll assume it was fixed.


Note You need to log in before you can comment on or make changes to this bug.