Bug 684399 - Parted crash while making live-usb
Parted crash while making live-usb
Status: CLOSED DUPLICATE of bug 585468
Product: Fedora
Classification: Fedora
Component: parted (Show other bugs)
14
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-12 04:54 EST by moabi2000
Modified: 2011-03-12 10:29 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-12 10:29:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description moabi2000 2011-03-12 04:54:51 EST
Description of problem:

Parted crashes when trying to print partition info. 

I followed exactly CLI instructions on http://fedoraproject.org/wiki/FedoraLiveCD/USBHowTo to partion, format and install liveusb image. When trying to mark the usb key bootable, parted crashes:

[root@localhost ~]# parted /dev/sdb
GNU Parted 2.3
Using /dev/sdb
Welcome to GNU Parted! Type 'help' to view a list of commands.
                                                                      (parted) print
Backtrace has 13 calls on stack:
  13: /lib64/libparted.so.0(ped_assert+0x31) [0x304b412011]
  12: /lib64/libparted.so.0() [0x304b43bc4e]
  11: /lib64/libparted.so.0() [0x304b43c30e]
  10: /lib64/libparted.so.0() [0x304b43e39b]
  9: /lib64/libparted.so.0(ped_disk_add_partition+0x1cf) [0x304b417ecf]
  8: /lib64/libparted.so.0() [0x304b43d900]
  7: /lib64/libparted.so.0() [0x304b43dd73]
  6: /lib64/libparted.so.0(ped_disk_new+0x75) [0x304b418315]
  5: parted() [0x4059f1]
  4: parted(interactive_mode+0xf3) [0x40dab3]
  3: parted(main+0x146f) [0x40aa8f]
  2: /lib64/libc.so.6(__libc_start_main+0xfd) [0x304441ee5d]
  1: parted() [0x404f69]
                                                                          

You found a bug in GNU Parted! Here's what you have to do:

Don't panic! The bug has most likely not affected any of your data.
Help us to fix this bug by doing the following:

Check whether the bug has already been fixed by checking
the last version of GNU Parted that you can find at:

        http://ftp.gnu.org/gnu/parted/

Please check this version prior to bug reporting.

If this has not been fixed yet or if you don't know how to check,
please visit the GNU Parted website:

        http://www.gnu.org/software/parted

for further information.

Your report should contain the version of this release (2.3)
along with the error message below, the output of

        parted DEVICE unit co print unit s print

and the following history of commands you entered.
Also include any additional information about your setup you
consider important.

Assertion (head_size <= 63) at dos.c:661 in function
probe_partition_for_geom() failed.

Aborted (core dumped)
[root@localhost ~]# 







Version-Release number of selected component (if applicable):


How reproducible:

Every time.


Steps to Reproduce:
1.insert but do not mount usb key
2.parted /dev/sdX
3.print
  
Actual results:


Expected results:


Additional info:
Comment 1 Brian Lane 2011-03-12 10:29:57 EST
You can fix this by erasing the first few blocks of the device with dd if=/dev/zero bs=512 count=100 of=/dev/blah

*** This bug has been marked as a duplicate of bug 585468 ***

Note You need to log in before you can comment on or make changes to this bug.