Bug 684653 - Screen unlocking fails after having locked screen in gnome-shell
Screen unlocking fails after having locked screen in gnome-shell
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gnome-shell (Show other bugs)
15
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Owen Taylor
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-14 02:46 EDT by Joachim Backes
Modified: 2011-03-17 09:37 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-17 09:37:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Backes 2011-03-14 02:46:35 EDT
Description of problem:
I lock my screen with the rightmost top button menu "Lock screen". Now trying to unlock fails because my password is not accepted. But if I try to switch user to my own UID and then entering the password, it is accepted, and the (old) session is reopened.

Version-Release number of selected component (if applicable):
gnome-shell-2.91.91-1.fc15.x86_64

How reproducible:
always

Steps to Reproduce:
1.Login into gnome-shell
2.Lock screen as described
3.Try to unlock the screen
  
Actual results:
password is not accepted, screen remains locked

Expected results:
screen is unlocked

Additional info:
Comment 1 Joachim Backes 2011-03-16 03:46:46 EDT
Contents of /var/log/secure in this situation:

Mar 16 08:43:37 eule unix_chkpwd[3983]: check pass; user unknown
Mar 16 08:43:42 eule unix_chkpwd[3984]: check pass; user unknown
Mar 16 08:43:42 eule unix_chkpwd[3984]: password check failed for user (backes)
Mar 16 08:43:42 eule gnome-screensaver-dialog: pam_unix(gnome-screensaver:auth): authentication failure; logname= uid=500 euid=500 tty=:0.0 ruser= rhost=  user=backes
Comment 2 Joachim Backes 2011-03-17 09:37:00 EDT
Problem solved: /bin/su had no s-bit. After adding the s-bit to /bin/su, unlocking runs perfectly.

I can't say why that bit was missing :-(

Note You need to log in before you can comment on or make changes to this bug.