Bug 68474 - installer hangs on second CD
installer hangs on second CD
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-10 11:26 EDT by Randy Kelsoe
Modified: 2007-04-18 12:44 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-17 20:45:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
file dumped from anaconda (87.93 KB, text/plain)
2002-07-10 11:27 EDT, Randy Kelsoe
no flags Details

  None (edit)
Description Randy Kelsoe 2002-07-10 11:26:10 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:0.9.9) Gecko/20020513

Description of problem:
When trying to install 7.3, when I got to the second CD, it would crash and
identify itself as a bug. This happened several times. The bug was copied to a
floppy.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Start install
2.Let 1st CD finish
3.install 2nd CD
4. stops in the middle with an error
	

Actual Results:  I let anaconda copy the bug message to a floppy. I restarted
the install    
2 more times and had the same error. I then tried to install using a SGI XFS 1.1
install disk, which in turn uses the 3 RedHat 7.3 disks, and the install succeeded. 

Expected Results:  The install should have completed.

Additional info:

Traceback (innermost last):
  File "/usr/bin/anaconda", line 633, in ?
    intf.run(id, dispatch, configFileData)
  File "/usr/lib/anaconda/gui.py", line 353, in run
    self.icw.run (self.runres, configFileData)
  File "/usr/lib/anaconda/gui.py", line 814, in run
    mainloop ()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2676, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/anaconda/gui.py", line 529, in handleRenderCallback
    self.currentWindow.renderCallback()
  File "/usr/lib/anaconda/iw/progress_gui.py", line 135, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib/anaconda/gui.py", line 417, in nextClicked
    self.dispatch.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 144, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 209, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/packages.py", line 611, in doInstall
    problems = ts.run(0, ~rpm.RPMPROB_FILTER_DISKSPACE, cb.cb, 0)
  File "/usr/lib/anaconda/packages.py", line 244, in cb
    fn = self.method.getFilename(h, self.pkgTimer)
  File "/usr/lib/anaconda/image.py", line 86, in getFilename
    isys.umount("/mnt/source")
  File "/usr/lib/anaconda/isys.py", line 171, in umount
    rc = _isys.umount(what)
SystemError: (16, 'Device or resource busy')

My hardware: ECS K7S5A MB, Athlon XP 1600, ATI Radeon VE (DDR)
Comment 1 Randy Kelsoe 2002-07-10 11:27:40 EDT
Created attachment 64609 [details]
file dumped from anaconda
Comment 2 Michael Fulbright 2002-07-10 14:46:38 EDT
Please test your CDs following these instructions:

  http://people.redhat.com/~msf/mediacheck.html
Comment 3 Randy Kelsoe 2002-07-10 19:40:32 EDT
Sorry, I forgot to mention that before I burned the CD's, I checked the MD5
sums, and also ran the 'linux mediacheck' on all three of my CD's. The MD5 sums
were identical, and all three disks passed mediacheck.
RK
Comment 4 Michael Fulbright 2002-07-17 17:46:27 EDT
These errors:

<4>end_request: I/O error, dev 16:00 (hdc), sector 1290980
<4>hdc: irq timeout: status=0xd0 { Busy }
<4>hdc: ATAPI reset complete

indicate the drive was not able to read the CD during the install.  Since the
install program accesses the drive differently than the mediacheck, sometimes it
will pass the mediacheck and fail during an install.

I would recommend trying a different CD drive.

Comment 5 Randy Kelsoe 2002-07-17 20:45:33 EDT
Thanks for your comments. This was the second CD drive I tried. The first would
always hang the install when trying to load the timidity rpm. Please read the
notes above. I was finally able to install 7.3 with the SGI XFS 1.1 installer
CD, and I used the same CD ROM drive, and the same 3 RedHat 7.3 CD's. I am not
sure what is different between the SGI installer and the RedHat installer, but
the SGI installer works and the RedHat does not.
Comment 6 Michael Fulbright 2002-08-12 18:01:26 EDT
Good to hear.

Note You need to log in before you can comment on or make changes to this bug.