Bug 68487 - CUPS fails to print plain text files
CUPS fails to print plain text files
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: cups (Show other bugs)
7.3
i386 Linux
high Severity high
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-10 12:25 EDT by Willem Scholten
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-28 05:29:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Willem Scholten 2002-07-10 12:25:26 EDT
Description of Problem:

When submitting a plain text file to a CUPS managed printer, the coversion 
process - texttops - pstosp - pstoraster etc fails.  From the error logs it 
appears that texttops is the step whcih fails by creating a files with 'errors' 
in it.

The printer works fine, since sending postscript, pdf or even png files has the 
expected printing results.  Further sending a the text file with lpr -o raw 
will also cause the file to print, ofcourse missing all the form feeds etc :)

Further, I have tried this on 3 different printers all fail when text printing.
I have further tried the inclusion of FontPath in cupsd.conf pointing to the 
Ghostscript fonts irectory, at the suggestion by soemone that likely the 
appropriate ghostscript fonts could not be found, it does not change the 
effect/error!

Version-Release number of selected component (if applicable):

CUPS-1.1.14-5 base rpm as foudn on 7.3 install disks

How Reproducible:

Sending a plain text file to ANY cups managed printer.

Steps to Reproduce:
1. lpr test.txt 

where test.txt is a basic text file in my case:
Hello Printer
Are we feeling fine today?
+++++++ a text line ++++++++
Goodbye

2. 
3. 

Actual Results:

Cups aborts - see error_log

Expected Results:

Printign of a text file on the printer :)

Additional Information:
	
I can submit the error_log of the process of conversion when submitting the 
text file to the printer.
Comment 1 Tim Waugh 2002-09-26 03:23:33 EDT
>I can submit the error_log of the process of conversion when submitting the  
>text file to the printer. 
 
Please do. 
 
Thanks.
Comment 2 Tim Waugh 2003-05-28 05:29:01 EDT
Closing, no feedback.

Note You need to log in before you can comment on or make changes to this bug.