Bug 685049 - XP-32 get BSOD when run "Plug and Play Driver Test" for BLK WHQL testing
XP-32 get BSOD when run "Plug and Play Driver Test" for BLK WHQL testing
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xenpv-win (Show other bugs)
5.7
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Paolo Bonzini
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-15 03:04 EDT by Huang Wenlong
Modified: 2013-10-20 17:42 EDT (History)
8 users (show)

See Also:
Fixed In Version: xenpv-win-1.3.11-1.el5
Doc Type: Bug Fix
Doc Text:
Cause - A variable was not reset to NULL when Windows sent a ScsiStopAdapter control message to the RHELSCSI driver. Consequence - When running the debug version of the drivers on Windows XP, an assertion failure would be reported during hibernation. Fix - The stored device extension is reset to NULL when the adapter is stopped. Result - The assertion failure does not happen anymore.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-21 00:35:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
BSOD screenshut (30.21 KB, image/png)
2011-03-15 03:05 EDT, Huang Wenlong
no flags Details
crashdump file analysis (4.91 KB, text/plain)
2011-03-15 03:05 EDT, Huang Wenlong
no flags Details

  None (edit)
Description Huang Wenlong 2011-03-15 03:04:18 EDT
Description of problem:
XP-32 get BSOD when run "Plug and Play Driver Test" for BLK WHQL testing 


Version-Release number of selected component (if applicable):
xenpv-win-1.3.4-6.el5.rpm
kernel-xen-2.6.18-245.el5.x86_64.rpm
xen-3.0.3-123.el5.x86_64.rpm


How reproducible:
100%

Steps to Reproduce:
1.install xenpv-win driver 
2.set register EnumerateDevicesOverride = 3
3.run test job

  
Actual results:
guest get BSOD 

Expected results:
test job will pass 

Additional info:
Comment 1 Huang Wenlong 2011-03-15 03:05:17 EDT
Created attachment 484376 [details]
BSOD screenshut

BSOD screenshut
Comment 2 Huang Wenlong 2011-03-15 03:05:57 EDT
Created attachment 484377 [details]
crashdump file analysis

crashdump file analysis
Comment 9 Qin Guan 2011-11-28 00:36:47 EST
Verify that no BSOD found with xenpv-win-1.3.12-2.el5 and WLK1.6 for XP 32bit.
Comment 10 Paolo Bonzini 2012-01-16 04:07:06 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause - A variable was not reset to NULL when Windows sent a ScsiStopAdapter control message to the RHELSCSI driver.

Consequence - When running the debug version of the drivers on Windows XP, an assertion failure would be reported during hibernation.

Fix - The stored device extension is reset to NULL when the adapter is stopped.

Result - The assertion failure does not happen anymore.
Comment 11 errata-xmlrpc 2012-02-21 00:35:15 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0195.html

Note You need to log in before you can comment on or make changes to this bug.