Bug 685098 - [abrt] system-config-printer-1.3.1-1.fc15: authconn.py:197:_connect:RuntimeError: failed to connect to server
Summary: [abrt] system-config-printer-1.3.1-1.fc15: authconn.py:197:_connect:RuntimeEr...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-printer
Version: 15
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:1cef6c6e
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-03-15 09:50 UTC by Vít Ondruch
Modified: 2011-03-23 04:59 UTC (History)
2 users (show)

Fixed In Version: system-config-printer-1.3.2-1.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-03-23 04:59:48 UTC


Attachments (Terms of Use)
File: backtrace (793 bytes, text/plain)
2011-03-15 09:50 UTC, Vít Ondruch
no flags Details

Description Vít Ondruch 2011-03-15 09:50:47 UTC
abrt version: 1.1.17
architecture: x86_64
cmdline: /usr/bin/python /usr/share/system-config-printer/system-config-printer.py
component: system-config-printer
executable: /usr/share/system-config-printer/system-config-printer.py
kernel: 2.6.38-0.rc8.git0.1.fc15.x86_64
package: system-config-printer-1.3.1-1.fc15
reason: authconn.py:197:_connect:RuntimeError: failed to connect to server
release: Fedora release 15 (Lovelock)
time: 1300182557
uid: 500

backtrace
-----
authconn.py:197:_connect:RuntimeError: failed to connect to server

Traceback (most recent call last):
  File "/usr/share/system-config-printer/system-config-printer.py", line 751, in on_server_settings_activate
    parent=self.PrintersWindow)
  File "/usr/share/system-config-printer/serversettings.py", line 68, in __init__
    self.cupsconn = authconn.Connection (host=host, encryption=encryption)
  File "/usr/share/system-config-printer/authconn.py", line 165, in __init__
    self._connect ()
  File "/usr/share/system-config-printer/authconn.py", line 197, in _connect
    encryption=self._encryption)
RuntimeError: failed to connect to server

Local variables in innermost frame:
self: <authconn.Connection instance at 0x22f4878>
allow_pk: True
create_object: <type 'cups.Connection'>

How to reproduce
-----
1. Unsuccessfully tried to connec to some cups server
2. Tried to open settings gialog
3.

Comment 1 Vít Ondruch 2011-03-15 09:50:50 UTC
Created attachment 484417 [details]
File: backtrace

Comment 2 Tim Waugh 2011-03-16 16:43:52 UTC
Fixed in a82dbd8.

Comment 3 Fedora Update System 2011-03-18 17:26:06 UTC
system-config-printer-1.3.2-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/system-config-printer-1.3.2-1.fc15

Comment 4 Fedora Update System 2011-03-23 04:59:19 UTC
system-config-printer-1.3.2-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.