Bug 685234 - multiprocessing.Process.start() fails occasionally
multiprocessing.Process.start() fails occasionally
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: python (Show other bugs)
6.1
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Dave Malcolm
Petr Šplíchal
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-15 09:34 EDT by Rami Vaknin
Modified: 2016-05-31 21:41 EDT (History)
8 users (show)

See Also:
Fixed In Version: python-2.6.6-21.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
RHEL6.1, python 2.6
Last Closed: 2011-12-06 05:24:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Rami Vaknin 2011-03-15 09:34:06 EDT
It seems that forking._cleaup() calls Popen.poll() which tests for self.returncode, but then self.pid may be collected by another .poll() and refer to a nonexistent pid.


MainThread::ERROR::2011-03-14 18:02:48,144::sp::548::Storage.StoragePool::(reconnect) RECONNECT: Failed: 1cceaba4-2aec-45fe-b4f7-eac35299698d
Traceback (most recent call last):

    File "/usr/share/vdsm/storage/sp.py", line 546, in reconnect
        return self.connect(hostId, scsiKey, msdUUID, masterVersion)
    File "/usr/share/vdsm/storage/sp.py", line 434, in connect
        SDF.refresh()
    File "/usr/share/vdsm/storage/sdf.py", line 132, in refresh
        cls.sdc.refresh()
    File "/usr/share/vdsm/storage/sdc.py", line 114, in refresh
        self._refreshDomains()
    File "/usr/share/vdsm/storage/misc.py", line 1028, in helper
        return sm(*args, kwargs)
    File "/usr/share/vdsm/storage/misc.py", line 1015, in call
        self.lastResult = self.func(*args, kwargs)
    File "/usr/share/vdsm/storage/sdc.py", line 140, in _refreshDomains
        nfsSD.getFileStorageDomainList() +
    File "/usr/share/vdsm/storage/nfsSD.py", line 146, in getFileStorageDomainList
        dl.append(NfsStorageDomain?(os.path.basename(os.path.dirname(f))))
    File "/usr/share/vdsm/storage/fileSD.py", line 87, in init
        if not oop.fileUtils.pathExists(self.metafile):
    File "/usr/share/vdsm/storage/processPool.py", line 35, in wrapper
        return self.runExternally(func, *args, kwds)
    File "/usr/share/vdsm/storage/processPool.py", line 54, in runExternally
        helper = Helper()
    File "/usr/share/vdsm/storage/processPool.py", line 102, in init
        self.proc.start()
    File "/usr/lib64/python2.6/multiprocessing/process.py", line 99, in start
        _cleanup()
    File "/usr/lib64/python2.6/multiprocessing/process.py", line 53, in _cleanup
        if p._popen.poll() is not None:
    File "/usr/lib64/python2.6/multiprocessing/forking.py", line 106, in poll
        pid, sts = os.waitpid(self.pid, flag)
OSError: [Errno 10] No child processes
Comment 2 RHEL Product and Program Management 2011-04-03 22:13:13 EDT
Since RHEL 6.1 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 15 errata-xmlrpc 2011-12-06 05:24:02 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1564.html

Note You need to log in before you can comment on or make changes to this bug.