This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 68533 - System Hangs On Boot
System Hangs On Boot
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
8.0
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks: 74749
  Show dependency treegraph
 
Reported: 2002-07-10 19:41 EDT by Nick Uniatowski
Modified: 2008-08-01 12:22 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 11:39:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nick Uniatowski 2002-07-10 19:41:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:0.9.4.1)
Gecko/20020314 Netscape6/6.2.3

Description of problem:
The installer went smoothly. I chose a custom install, selected everything but
games, dns, and windows server. Upon rebooting the system froze on loading Init
after freeing unused kernel memory and mounting the root fs. I dont think the
filesystem is mounting, however no errors are listed. I booted in rescue mode
and the root fs mounted fine, so its not the partitions.

The system config is:

Processor: 1ghz Athlon
Motherboard: Jabil AMD Motherboard R4 (AMD 750, consisting of the AMD 751
Irongate North bridge and the AMD 756 Viper South bridge)
Memory: 512mb
Controller: Promise Ultra100 PCI
NIC: 3com 10/100 PCI
Sound: SB Live Value
Video: Nvidia Geforce 2 GTS
Mouse: MS Intellimouse
Keyboard: PS/2 Keyboard.

The system has 2 HDs.
Drive 1: is WinXP (hde)
Drive 2: has 2 partions.  / (hdf1)  swap (hdf2)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start machine
2.
3.
Comment 1 Roel Gloudemans 2002-07-24 04:24:15 EDT
I've had the same. I solved the problem by creating a new initrd image
Comment 2 Arjan van de Ven 2002-07-26 08:45:03 EDT
would  you be able to try ide=nodma as grub commandline option?
Comment 3 Nick Uniatowski 2002-07-26 10:21:41 EDT
I tried passing ide=nodma as a kernel arguement. Same result. System completely
locks up after mounting the root fs.
Comment 4 Nick Uniatowski 2002-07-31 10:34:53 EDT
Problem still exists in 7.3.93.
Comment 5 Nick Uniatowski 2002-08-06 18:55:48 EDT
Tried different boot options as suggested (apic, noapic, nohlt). Same result.
System freezes on Init booting.
Comment 6 Warren Togami 2002-08-13 07:28:28 EDT
I have seen this exact problem on a Red Hat 7.3 (Pentium III) and Limbo2
(Athlon) machine today.  Ended up booting into rescue and re-installing the
kernel, then things were back to normal.  I have no clue how it became this way.
Comment 7 Nick Uniatowski 2002-08-15 09:17:58 EDT
I tried to boot into rescue mode and re-install the athlon kernel using rpm -
ivh kernel-whatever --replacefiles --replacepkgs.  The system still hangs on 
boot. After installing the kernel rpm, depmod returned this msg:

depmod: *** Unresolved symbols in /lib/modules/2.4.18-
7.80/kernel/arch/i386/kernel/longhaul.o

depmod: cpufreq_unregister_Rcf4ba771
depmod: cpufreq_register_Ra6b98f00

depmod: *** Unresolved symbols in /lib/modules/2.4.18-
7.80/kernel/arch/i386/kernel/p4-clockmod.o

depmod: cpufreq_unregister_Rcf4ba771
depmod: cpufreq_register_Ra6b98f00

depmod: *** Unresolved symbols in /lib/modules/2.4.18-
7.80/kernel/arch/i386/kernel/speedstep.o

depmod: cpufreq_unregister_Rcf4ba771
depmod: cpufreq_register_Ra6b98f00

hope this helps.
Comment 8 Nick Uniatowski 2002-08-20 12:12:10 EDT
Problem still exists in 7.3.94(Null).
Comment 9 Alan Cox 2002-08-21 15:41:56 EDT
I'll take a look at this one and double check it. I've got a 751/756 providing
it'll boot the Null CD. (I blew the floppy controller up 8))
Comment 10 Nick Uniatowski 2002-08-28 13:43:18 EDT
I found a site with a lot of info about the board and links to additional
information:

http://bratlady.com/Jabil_Motherboard.shtml

also, mine has the bios upgrade installed and I am using a athlon 1ghz tbird.
Comment 11 Andrew Sobala 2003-04-07 14:24:12 EDT
Duplicate of bug 74749
Comment 12 Bugzilla owner 2004-09-30 11:39:44 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.