Bug 68542 - rpm crash
rpm crash
Status: CLOSED DUPLICATE of bug 67108
Product: Red Hat Public Beta
Classification: Retired
Component: rpm (Show other bugs)
limbo
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-10 21:23 EDT by Kris Urquhart
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-10 21:23:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kris Urquhart 2002-07-10 21:23:50 EDT
Description of Problem:
I copied all the RPMs off of the first 3 limbo CDs.

# rpm -ihv *.rpm
<snip>
warning: keduca-3.0.1-2.i386.rpm: Header V3 DSA signature: NOKEY, key ID 897da07a
warning: kernel-2.4.18-5.58.i386.rpm: Header V3 DSA signature: NOKEY, key ID
897da07a
warning: kernel-2.4.18-5.58.i586.rpm: Header V3 DSA signature: NOKEY, key ID
897da07a
warning: package kernel = 2.4.18-5.58 was already added, replacing with kernel
<= 2.4.18-5.58
Segmentation fault


If I limit the install to just the kernels, rpm hangs instead of crashing:
# rpm -ihv kernel*.rpm
warning: kernel-2.4.18-5.58.i386.rpm: Header V3 DSA signature: NOKEY, key ID
897da07a
warning: kernel-2.4.18-5.58.i586.rpm: Header V3 DSA signature: NOKEY, key ID
897da07a
warning: package kernel = 2.4.18-5.58 was already added, replacing with kernel
<= 2.4.18-5.58
<hang>



Version-Release number of selected component (if applicable):
rpm-4.1-0.34


How Reproducible:
Very
Comment 1 Jeff Johnson 2002-07-11 12:55:24 EDT

*** This bug has been marked as a duplicate of 67108 ***

Note You need to log in before you can comment on or make changes to this bug.