Bug 68557 - redhat-mouse-config crashes with internal touchpoint on x20 thinkpad
redhat-mouse-config crashes with internal touchpoint on x20 thinkpad
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: redhat-config-mouse (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
: 68596 69681 (view as bug list)
Depends On:
Blocks: 67217
  Show dependency treegraph
 
Reported: 2002-07-11 00:33 EDT by mark krischer
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-02 00:34:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mark krischer 2002-07-11 00:33:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020625

Description of problem:
first noticed when firstboot runs.  clicking on the config button for mouse just
died.  the i tried runnning it from the command line and python died as detailed
below.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.execute redhat-config-mouse from either firstboot, or afterwards directly from
the command line.
	

Actual Results:  [root@random root]# redhat-config-mouse
[]
Traceback (most recent call last):
  File "/usr/share/redhat-config-mouse/redhat-config-mouse.py", line 13, in ?
    app.stand_alone()
  File "/usr/share/redhat-config-mouse/mouse_gui.py", line 214, in stand_alone
    self.setupScreen()
  File "/usr/share/redhat-config-mouse/mouse_gui.py", line 51, in setupScreen
    self.probedMouse = self.probeMouse()
  File "/usr/share/redhat-config-mouse/mouse_gui.py", line 142, in probeMouse
    lines = string.split(str(mouse[0]), '\n')
IndexError: list index out of range


Additional info:

i'm running on an X20 thinkpad, and using the internal touchpoint.  the mouse,
btw, works fine.  it's just this config app that doesn't work.
Comment 1 Brent Fox 2002-07-11 11:53:35 EDT
*** Bug 68596 has been marked as a duplicate of this bug. ***
Comment 2 Brent Fox 2002-07-24 22:47:48 EDT
*** Bug 69681 has been marked as a duplicate of this bug. ***
Comment 3 Brent Fox 2002-08-08 23:14:48 EDT
Should be fixed with 0.9.9-2.

QA, please verify.
Comment 4 Jay Turner 2002-08-29 22:22:19 EDT
I don't have an x20 at my disposal, so could the reporter grab the latest
redhat-config-mouse out of Rawhide and give this a try and let me know if things
are working now?
Comment 5 mark krischer 2002-09-02 00:34:02 EDT
unfortunately i've since gone back to redhat 7.3.  i did try and install the
requisite rpms (rhpl-0.51-1.i386.rpm redhat-config-mouse-1.0.1-2.noarch.rpm
pyxf86config-0.3.1-2.i386.rpm), and got the following response:

> sudo redhat-config-mouse
Traceback (innermost last):
  File "/usr/share/redhat-config-mouse/redhat-config-mouse.py", line 5, in ?
    import mouse_gui
  File "/usr/share/redhat-config-mouse/mouse_gui.py", line 30
    import rhpl.mouse as mouse
                       ^
SyntaxError: invalid syntax

i got the same response running as a user, and with sudo.
Comment 6 Jay Turner 2002-09-03 14:50:58 EDT
OK, since I don't have access to this type of machine, just going to have to
resolve it and have you reopen if you find problems.

Note You need to log in before you can comment on or make changes to this bug.