This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 68558 - man causes problems in x terminals with tcsh
man causes problems in x terminals with tcsh
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: man (Show other bugs)
8.0
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Eido Inoue
Ben Levenson
:
Depends On:
Blocks: 67218 79579
  Show dependency treegraph
 
Reported: 2002-07-11 01:06 EDT by mark krischer
Modified: 2007-04-18 12:44 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-19 15:55:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mark krischer 2002-07-11 01:06:52 EDT
Description of Problem:
when using man, it complains about gzip and grotty as shown below when run from
an xterm or gnome-terminal and a user account.  and from the console it shows
bizaare characters on user accounts.  it seems to work fine for root.

Version-Release number of selected component (if applicable):


How Reproducible:
every time

Steps to Reproduce:
1. in an xterm or gnome, use a user account with tcsh and get the output below

Actual Results:
the man page shows up as normal, but when you press 'q' to quit, the following
error messages are visable

[mkrisch@random ~]$ man man

gunzip: stdout: Broken pipe

gunzip: stdout: Broken pipe
grotty:<standard input>:4220:fatal error: output error


Expected Results:


Additional Information:
Comment 1 Jake Gage 2002-12-03 14:17:55 EST
  Don't mean to add chatter to the bug, but I'm experiencing the same problem,
though not with the requirements set.

  Recieve the same error in both bash and tcsh, but only when running
gnome-terminal (not xterm).  Like the above bug, this only seems to occur for
user accounts: when using an instance of gnome-terminal running as root, I can't
reproduce the problem.

  My install is a standard RH8, to reproduce:

1. Open a gnome-terminal session as a non-root user (bash or tcsh shell).
2. Type "man find"
3. Quit the manual page to see the output:

----

gunzip: stdout: Broken pipe

gunzip: stdout: Broken pipe
grotty:<standard input>:6110:fatal error: output error
----

  The problem is reproducable for many man pages.  The numbers in the fatal
error message vary by man page ("man man" will produce the number 4182, "man ls"
produces 2185).  Some manual pages do not seem to produce the error, for example
"man test" and "man help".

  This may be related to a problem I'm having trying to display man pages from
within the screen program.  Screen doesn't seem to be translating output
correctly, though the terminal settings are correct.  The same setup was fine
for RH7.X.  If anyone's run into anything like this, I'd be much obliged for a
bug reference.

  If I can provide anything more which may be helpful, please let me know. 
Thanks much.
Comment 2 dudek 2003-02-06 12:51:56 EST
I too have encountered these error messages when displaying man pages in
gnome-terminal with tcsh.  However, this is only one of two problems that I
encounter with the man pages.  I also see "funny characters" when I view the man
pages.  I seem to get one or both of these problems whenever I view a man page.
 I am not sure under which conditions each happens.  These problems occur on two
very different (hardware-wise) IA32 systems, both with fresh installs of RedHat
8.0 plus the latest updates via up2date.

I am relatively new to bugzilla and the bug-tracking community, so please let me
know what other information I need to provide.
Comment 3 dudek 2003-02-06 12:57:16 EST
I just realised that the "funny characters" occur when I'm using screen.  When I
use screen, I do not see the errors regarding gunzip and grotty.  When I am not
using screen, the pages look okay, but I get the gunzip/grotty errors.
Comment 4 Eido Inoue 2003-02-19 15:55:32 EST
fixed with the latest ncurses (funny chars) and groff updates.

Note You need to log in before you can comment on or make changes to this bug.