Bug 68560 - compile of XFree does not work (ttmkfdir2 breaks)
compile of XFree does not work (ttmkfdir2 breaks)
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-11 02:39 EDT by josef radinger
Modified: 2007-04-18 12:44 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-11 02:39:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description josef radinger 2002-07-11 02:39:28 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020701

Description of problem:
rpm-build breaks in ttmkfdir2
i updated freetype, but it didnt work either

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
rpm --rebuild --target i686 XFree86-4.2.0-52.01.src.rpm

freetype 2.1.2-3
gcc 2.96-98

Actual Results:  rm -f .libs/ttf.lo
g++ -Wall -pedantic -I/usr/include/freetype2/. -O2 -march=i686 -c ttf.cpp     -f
PIC -DPIC
ttf.cpp: In method `const char *ttf::Face::Weight () const':
ttf.cpp:519: warning: `const char *result' might be used uninitialized 
in this function
ttf.cpp: In method `const char *ttf::Face::Width () const':
ttf.cpp:600: warning: `const char *result' might be used uninitialized 
in this function
mv -f ttf.o .libs/ttf.lo
g++ -Wall -pedantic -I/usr/include/freetype2/. -O2 -march=i686 -c ttf.cpp >/dev/
null 2>&1
mv -f .libs/ttf.lo ttf.lo
libtool --mode=compile g++ -Wall -pedantic -I/usr/include/freetype2/. -O2 -march
=i686 -o encoding.o -c encoding.cpp
rm -f .libs/encoding.lo
g++ -Wall -pedantic -I/usr/include/freetype2/. -O2 -march=i686 -c encoding.cpp  
   -fPIC -DPIC
encoding.cpp: In method `Encoding::Encoding (Encodings_t *, 
Encoding::BuiltinEncoding_t *)':
encoding.cpp:100: warning: comparison between signed and unsigned 
integer expressions
mv -f encoding.o .libs/encoding.lo
g++ -Wall -pedantic -I/usr/include/freetype2/. -O2 -march=i686 -c encoding.cpp >
/dev/null 2>&1
mv -f .libs/encoding.lo encoding.lo
flex -i -8 -oparser.cpp encoding.l
libtool --mode=compile g++ -Wall -pedantic -I/usr/include/freetype2/. -O2 -march
=i686 -o parser.o -c parser.cpp
rm -f .libs/parser.lo
g++ -Wall -pedantic -I/usr/include/freetype2/. -O2 -march=i686 -c parser.cpp    
 -fPIC -DPIC
encoding.l: In function `int yylex (char *, Encodings_t &)':
encoding.l:144: warning: comparison between signed and unsigned integer 
expressions
encoding.l:114: warning: `int start_range' might be used uninitialized 
in this function
encoding.l:114: warning: `int end_range' might be used uninitialized in 
this function
encoding.l:114: warning: `int target' might be used uninitialized in 
this function
parser.cpp: At top level:
parser.cpp:1505: declaration of `int isatty (int)' throws different 
exceptions
/usr/include/unistd.h:668: than previous declaration `int isatty (int) 
throw ()'
parser.cpp:1284: warning: `void yyunput (int, char *)' defined but not 
used
make: *** [parser.o] Error 1
make: Leaving directory `/usr/src/redhat/BUILD/XFree86-4.2.0/ttmkfdir2'
error: Bad exit status from /var/tmp/rpm-tmp.66531 (%build)


Additional info:
Comment 1 Mike A. Harris 2002-07-13 00:55:50 EDT
XFree86 4.2.0 src.rpm is not intended to work in Red Hat Linux 7.0.  This is
not a bug.  It is impossible to make every rpm package, and in particular
a large package such as XFree86 compile with every possible compiler and
toolchain of every distro release without an amazing amount of complexity.
This is further made more complex by RPM spec files not allowing nested
conditionalization.

XFree86 should compile and work (without 3D acceleration) in Red Hat Linux
7.0 if you edit the specfile and tweak various things for the RHL 7.0
environment.  In the case of 7.0, one thing you'd want to do, is disable
ttmkfdir from being built at all, because it is included in the freetype
package itself in that release.  There is a conditional in the spec file
for this already "with_ttmkfdir".  You will need to tweak various other
things as well.

You're much better off however upgrading to Red Hat Linux 7.3 if you would
like to use XFree86 4.2.0.

Hope this helps.

Note You need to log in before you can comment on or make changes to this bug.