This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 68570 - Using 2 heartbeats - cluconfig will get wrong entry for heartbeat2 on node1
Using 2 heartbeats - cluconfig will get wrong entry for heartbeat2 on node1
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: clumanager (Show other bugs)
2.1
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Lon Hohberger
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-11 06:22 EDT by Paul McWatt
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-11 10:28:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Paul McWatt 2002-07-11 06:22:04 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2-2 i686)

Description of problem:
Using cluconfig for first time after a clean install. Using 2 heartbeats, they
can be either serial or network or mix. Cluconfig shows correct details but when
you start the cluster the second heartbeat is offline due to wrong entry for
heartbeat2 on node1.
Can be reproduced every time with a new installation.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install RHAS with Cluster Manager
2. Run cluconfig to setup nodes
3. At heartbeat section select heartbeat type
4. Manually enter text (/dev/ttyS0, IP or IP alias from /etc/hosts) heartbeat1
for node1
5. Manually enter text (/dev/ttyS0, IP or IP alias from /etc/hosts) heartbeat2
for node1
6. Go through rest of steps until heartbeat entries fo rnode2
7. Manually enter text (/dev/ttyS0, IP or IP alias from /etc/hosts) heartbeat1
for node2
8. Manually enter text (/dev/ttyS0, IP or IP alias from /etc/hosts) heartbeat2
for node2
9. Complete entries for cluconfig - program shows you the settings it plans to
save - these look okay so you accept config.
10. Run cluconfig --init=/dev/raw/raw1 on node2 - all okay.
11. Start cluster
12. Heartbeat2 will be offline. Check cluadmin --cluster status
13. Heartbeat2 on node1 will be entered as the hostname of node2 i.e "node2"
14. Running cluconfig again and changing the text fixes the problem.

Actual Results:  Heartbeat2 is offline.
Heartbeat2 in node1 has the wrong entry in cluster.conf

Expected Results:  After running cluconfig for the first time heartbeat2 should
be online and heartbeat2 on node1 should have the correct entry.

Additional info:

Apologies if you know about this already - i couldn't find anything similar on
the bugzilla site.

I have recreated the problem with clumanager-1.0.11-1.i386 and
clumanager-1.0.12beta-1.i386 which i was given to fix another problem (with
NFS).
Comment 1 Lon Hohberger 2002-07-18 17:04:06 EDT
I have reproduced and fixed this problem.  Thanks, Paul.

Note You need to log in before you can comment on or make changes to this bug.