This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 68602 - import gives bad results if X session being hit isn't current VT
import gives bad results if X session being hit isn't current VT
Status: CLOSED WONTFIX
Product: Red Hat Public Beta
Classification: Retired
Component: XFree86 (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks: 67218
  Show dependency treegraph
 
Reported: 2002-07-11 12:22 EDT by James Manning
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-13 18:54:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
sshot attempt of a fresh X (247.12 KB, image/png)
2002-07-11 12:24 EDT, James Manning
no flags Details
attempted shot of kde starting up (773.49 KB, image/png)
2002-07-11 16:42 EDT, James Manning
no flags Details
sshot of :0 when it wasn't the currently selected vt (778.16 KB, image/png)
2002-07-12 11:27 EDT, James Manning
no flags Details
XFree86.0.log - hopefully helpful if this is specific to the driver (23.93 KB, text/plain)
2002-07-13 18:54 EDT, James Manning
no flags Details

  None (edit)
Description James Manning 2002-07-11 12:22:26 EDT
Description of Problem:
see bug #68601 - basically attempting to import -window root on a fresh X gives
weird results

Version-Release number of selected component (if applicable):
ImageMagick-5.4.3.11-1

How Reproducible:
100%

Steps to Reproduce:
1. X :2 (or whatever's not taken)
2. import -display :2 -window root /tmp/sshot.png
3. kview /tmp/sshot.png (or whatever viewer)

Actual Results:
bizarre - i'll attach my sshot attempt results, although bug 68601 has it too

Expected Results:
an sshot that shows the black X cursor, gray background, etc.

Additional Information:
I'd guess it's because X hasn't really displayed anything yet, so what get
sshot'd it just the pattern that X inititialized the double-buffering location
(not in video ram I'd imagine) to - not sure though
Comment 1 James Manning 2002-07-11 12:24:10 EDT
Created attachment 64826 [details]
sshot attempt of a fresh X
Comment 2 James Manning 2002-07-11 16:41:35 EDT
actually, it looks like it's not just limited to that case - I just tried to
sshot KDE starting up just after I logged in to kdm and the results are just as
bad - attempted sshot to come
Comment 3 James Manning 2002-07-11 16:42:27 EDT
Created attachment 64984 [details]
attempted shot of kde starting up
Comment 4 James Manning 2002-07-12 11:25:14 EDT
ok, playing around some more, what looks to be the problem is that if the import
runs when the X server being import'd isn't the currently selected vt, then you
get the garbage sshot's.  Since import does the same in both cases, I'm more
likely to believe this is XF86's issue to deal with, so I'll change the assignment.

Mike - lemme know what I can do to debug this further
Comment 5 James Manning 2002-07-12 11:26:01 EDT
changing summary to better reflect the bug
Comment 6 James Manning 2002-07-12 11:27:39 EDT
Created attachment 65144 [details]
sshot of :0 when it wasn't the currently selected vt
Comment 7 James Manning 2002-07-13 18:54:08 EDT
Created attachment 65267 [details]
XFree86.0.log - hopefully helpful if this is specific to the driver
Comment 8 Mike A. Harris 2002-07-23 05:55:22 EDT
Multiple concurrant X servers do not simultaneously "share" the video
hardware.  They use it one at a time.  When you VTswitch out of one X
server, it completely restores the video card to it's state prior
to entering X, and switching to the other X server restores the video
state that that X server set up.

I'm not exactly sure I'd call this a bug.  However if it is in fact
a bug, there isn't anything I/we can do about it, as I have no Savage
video hardware or documentation, so any fixes will have to come
from the upstream XFree86 Savage video driver maintainer.  I recommend
discussing this on xpert@xfree86.org list to get a concensus of the
issue first, then contact Tim Roberts if it turns out to be considered
a bug.

Feel free to update this report with your findings, and if a patch or
fix results, I'll try to include it if possible.

Note You need to log in before you can comment on or make changes to this bug.