Bug 68611 - rpm should ignore users on source packages.
rpm should ignore users on source packages.
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: rpm (Show other bugs)
1.0
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-11 14:18 EDT by Aleksey Nogin
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-11 14:18:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aleksey Nogin 2002-07-11 14:18:14 EDT
With rpm-4.1-0.43.i386.rpm when installing a source package as non-priviledged
user, I see:

% rpm -Uvh /tmp/knetload-1.91-8mdk.src.rpm
warning: user baudens does not exist - using root
warning: user baudens does not exist - using root
warning: user baudens does not exist - using root
   1:knetload               ########################################### [100%]

I see two issues here:
- the "using root" is obviously a lie
- Shouldn't the "owner" tags in the source packages be ignored altogether (e.g.
even when installing as root and the named user does exist)?
Comment 1 Jeff Johnson 2002-07-11 14:48:57 EDT
The warning message is hardly a lie,
since it accurately indicates that, indeed,
the named user cannot be looked up and that
the uid of 0 is being substituted. You are
correct that final owner of the unpackaged
elements is not root, but that's impossible
to achieve in the situation you describe.

rpm does not "ignore" owners when installing
a package, never has.

Note You need to log in before you can comment on or make changes to this bug.