Bug 68616 - Installation problems dealing with graphics and sound
Installation problems dealing with graphics and sound
Status: CLOSED WONTFIX
Product: Red Hat Public Beta
Classification: Retired
Component: XFree86-Servers (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-11 14:40 EDT by Need Real Name
Modified: 2007-04-18 12:44 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-11 14:40:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-07-11 14:40:42 EDT
Description of Problem: Using a PNY Vertio GForce 4 4400 and a Soundblaster 
Audigy causes the following problems:

I believe that the GForce 4 does not support VESA (at least not properly). 
While the installation graphics worked great, the firstime bootup fails when 
it gets to the graphical system.
I tried to load the NVdriver, but to no avail, modprobe didn't find the card. 
I then tried my GForce 3 and it worked fine, but not with the NVdriver. With 
the GForce 3, the XF86Config-4 file showed that it was running with the VESA 
driver. 
When I reloaded limbo with the GForce3 installed, it used the nv driver and 
worked fine. That won't drive the GForce 4 though.

While the system identified my soundcard, the Audigy driver did not load and 
the mixer said that the drivers (module) may not have loaded.

By the way, there was no RPM graphical manager loaded. I could do it command 
line, but no graphical tool loaded.

Version-Release number of selected component (if applicable):


How Reproducible: Very


Steps to Reproduce:
1. Install product
2. 
3. 

Actual Results:


Expected Results:


Additional Information:
Comment 1 Mike A. Harris 2002-07-13 01:07:44 EDT
The GeForce 4 hardware is not supported at all in XFree86 4.2.0.  Rather than
having no video available at all, we set new unsupported video hardware to
use either the "vesa" or the "vga" driver by default.  That at least gives
a person a chance at having slow video than no video at all.  In order for
the "vesa" driver to work however, the video card's BIOS must implement
the VESA VBE properly.  If the BIOS contains bugs, then there isn't much
we can do to fix it if it does not work.

The installer does not use any of these drivers at all.  The installer
(anaconda) uses the XFree86 3.3.6 FBDev X server, which uses the kernel
framebuffer device for video.  We provide this X server as well if you
would like to use it, however you'll need to read the Framebuffer HOWTO
in order to configure your modules.conf properly and set it up.

Again though, the vesa driver and FBDev are only "provided" in a hope that
they will work.  The video hardware that is configured to use these drivers
by default however is officially unsupported.  We only officially support
hardware that is supported by XFree86 native drivers.

The GeForce 4 hardware will be supported in XFree86 4.3.0 later this year.

Also, we do not support the NVdriver from Nvidia.

Note You need to log in before you can comment on or make changes to this bug.