Bug 68625 - crash when clicking on partitions of 4th disk
crash when clicking on partitions of 4th disk
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda (Show other bugs)
limbo
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks: 67217
  Show dependency treegraph
 
Reported: 2002-07-11 15:53 EDT by Alexandre Oliva
Modified: 2007-04-18 12:44 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-19 13:14:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda crash dump (74.19 KB, text/plain)
2002-07-11 15:54 EDT, Alexandre Oliva
no flags Details
This patch fixes the problem. I don't understand why the bug doesn't show up on a 2-disks system :-( (1.24 KB, patch)
2002-08-15 00:04 EDT, Alexandre Oliva
no flags Details | Diff
It didn't show up because the bogus initializer of parentstack would hide it. This fixes it too. (1.24 KB, patch)
2002-08-15 00:25 EDT, Alexandre Oliva
no flags Details | Diff
A alternate patch I think is more correct (555 bytes, patch)
2002-08-15 01:36 EDT, Michael Fulbright
no flags Details | Diff

  None (edit)
Description Alexandre Oliva 2002-07-11 15:53:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1a) Gecko/20020610

Description of problem:
In a custom (or workstation) install with disk druid, anaconda crashes when I
click on any (graphical) partition it shows on hdg, even if clicking on similar
partitions in hda, hdc or hde works fine.

All 4 disks are identical, with 1 32MB partition as hd?1 and the rest as an
extended hd?2, containing 4855MB for hd?5, 256MB for hd?6 and the rest on hd?7.
 hd?1 and hd?5 form 2 RAID1 devices, and hd?6 and hd?7 form 2 RAID5 devices. 
I've observed problems clicking on both hdg5 and hdg7.  I'm not sure whether the
fact that the disks are RAID components matters.

Dunno if it matters, but hdg is the only disk that requires scrolling of the
graphical window to be displayed.  Clicking on any hdg? partition in the text
panel works, and highlights the corresponding partition in the graphical panel.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Start installation on a system with disk layout as above.
2.Choose disk druid for disk partitioning.
3.Scroll the graphical partition display and click on hdg5 or hdg7 (hdg1 and
hdg6 are too small to show up).

Actual Results:  Anaconda crashes.

Expected Results:  Erhm...  It should highlight that partition in both the
graphical and text panels.

Additional info:
Comment 1 Alexandre Oliva 2002-07-11 15:54:17 EDT
Created attachment 64944 [details]
Anaconda crash dump
Comment 2 Michael Fulbright 2002-07-17 17:04:30 EDT
Could you attach a listing of the partitions on the disk?
Comment 3 Alexandre Oliva 2002-07-17 17:20:35 EDT
Is this what you had in mind?  If not, is this enough?  The other three disks
(hdc, hde and hdg) are all identically partitioned.

Disk /dev/hda: 16 heads, 63 sectors, 119150 cylinders
Units = cylinders of 1008 * 512 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/hda1   *         1        65     32728+  fd  Linux raid autodetect
/dev/hda2            66    119150  60018840    f  Win95 Ext'd (LBA)
/dev/hda5            66      9929   4971424+  fd  Linux raid autodetect
/dev/hda6          9930     10455    265072+  fd  Linux raid autodetect
/dev/hda7         10456    119150  54782248+  fd  Linux raid autodetect
Comment 4 Michael Fulbright 2002-07-18 13:32:43 EDT
Thanks.
Comment 5 Michael Fulbright 2002-07-31 22:17:54 EDT
Is this a problem with limbo 2?
Comment 6 Alexandre Oliva 2002-08-01 12:45:22 EDT
'fraid so :-(
Comment 7 Michael Fulbright 2002-08-14 02:08:32 EDT
This machine isn't easily available for me to attach to remotely is it and run
anaconda in test mode via X redirected?
Comment 8 Alexandre Oliva 2002-08-14 11:42:51 EDT
Not easily, I'm afraid.  But I could do it tonight or tomorrow (I'm away from it
for all day today).  Other than that, I could try something myself, given some
pointers on what to do.  Perhaps we can do a remote debugging session on IRC or
something alike?
Comment 9 Michael Fulbright 2002-08-14 12:18:44 EDT
Yeah when are you usually around IRC? I'm on US East Coast time.
Comment 10 Alexandre Oliva 2002-08-15 00:04:11 EDT
Created attachment 70764 [details]
This patch fixes the problem.  I don't understand why the bug doesn't show up on a 2-disks system :-(
Comment 11 Alexandre Oliva 2002-08-15 00:25:29 EDT
Created attachment 70765 [details]
It didn't show up because the bogus initializer of parentstack would hide it.  This fixes it too.
Comment 12 Michael Fulbright 2002-08-15 01:36:28 EDT
Created attachment 70766 [details]
A alternate patch I think is more correct
Comment 13 Michael Fulbright 2002-08-15 01:36:54 EDT
Could you try this new patch please?
Comment 14 Alexandre Oliva 2002-08-15 12:36:29 EDT
Thanks, your patch does indeed look correct.
In fact, it looks so right that, now I can see we could do away entirely with
the `parent' variable, and just use parentstack[-1] all over.
Thanks for being so careful and not accepting my earlier patch :-)
Comment 15 Alexandre Oliva 2002-08-15 12:38:27 EDT
Oops.  Forgot to mention I've actually tested it, and it worked just fine.
Except that I had to reboot it again, because the contents of my /dev/md0 /l
filesystem became inaccessible again :-(  Even though I had run anaconda with
--test.
Comment 16 Michael Fulbright 2002-08-19 12:42:56 EDT
Thanks again for the help debugging this.
Comment 17 Alexandre Oliva 2002-08-19 13:14:54 EDT
NP, thanks for the help.  FWIW, I've managed to verify that the problem is gone
on (null).
Comment 18 Mike McLean 2002-08-20 14:12:47 EDT
CLOSED->RAWHIDE (based on reporter's comment)

Note You need to log in before you can comment on or make changes to this bug.