Bug 68639 - traceback if you click Properties without selecting a user/group
Summary: traceback if you click Properties without selecting a user/group
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: redhat-config-users (Show other bugs)
(Show other bugs)
Version: limbo
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 67217
TreeView+ depends on / blocked
 
Reported: 2002-07-11 22:49 UTC by Tammy Fox
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-14 00:54:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tammy Fox 2002-07-11 22:49:25 UTC
[root@ijin redhat-config-users]# Traceback (most recent call last):
  File "/usr/share/redhat-config-users/mainWindow.py", line 617, in
on_properties_activate
    self.user_properties()
  File "/usr/share/redhat-config-users/mainWindow.py", line 625, in user_properties
    userEnt = self.userStore.get_value(iter, 6)
TypeError: iter must be a GtkTreeIter

Comment 1 Tammy Fox 2002-07-11 22:50:32 UTC
Same thing happens if I don't select a group:

Traceback (most recent call last):
  File "/usr/share/redhat-config-users/mainWindow.py", line 619, in
on_properties_activate
    self.group_properties()
  File "/usr/share/redhat-config-users/mainWindow.py", line 632, in group_properties
    groupEnt = self.groupStore.get_value(iter, 3)
TypeError: iter must be a GtkTreeIter


Comment 2 Brent Fox 2002-07-14 00:21:57 UTC
Some thing happens if you click 'Delete' immediately.

Comment 3 Brent Fox 2002-07-14 00:54:10 UTC
Also happens with the menu items.

Comment 4 Brent Fox 2002-07-14 01:34:39 UTC
Fixed in cvs in redhat-config-users-1.1-2.  Can't rebuild right now because
Beehive is dead.  I will rebuild as soon as possible.  Thanks for your report.


Note You need to log in before you can comment on or make changes to this bug.