Bug 68666 - $TERM==screen gives bad results
$TERM==screen gives bad results
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: ncurses (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Eido Inoue
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-12 05:17 EDT by James Manning
Modified: 2015-01-07 18:57 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-19 15:56:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Manning 2002-07-12 05:17:24 EDT
Description of Problem:
I'm putty'd in from win2k to a 7.3 box and with the $TERM of screen, everything
is working fine on the 7.3 box - when I ssh from that session to a Limbo box,
the man doesn't work right - I'd guess related to the unicode switchover,
newt/minislang issues, etc.

Version-Release number of selected component (if applicable):
man-1.5j-8

How Reproducible:
100%

Steps to Reproduce:
1. screen session on 7.3 or earlier
2. ssh into Limbo box
3. man rpm (or whatever)

Actual Results:
some corrupted characters, the "first page" isn't a page, stops in the middle of
a line.  Trying to cut and paste it, here it is:

********
[root@localhost root]# man rpm
RPM(8)                    Red Hat Linux                    RPM(8)

NAME
       rpm b RPM Package Manager

SYNOPSIS
   QUERYING AND VERIFYING PACKAGES:
       rpm {b {b1mbb
********

when i hit the spacebar the first time, the display changes to:

********
[root@localhost root]# man rpm
RPM(8)                    Red Hat Linux                    RPM(8)

NAME
       rpm b RPM Package Manager

SYNOPSIS
   QUERYING AND VERIFYING PACKAGES:
       rpm {b {b1mbb1mbPACKAGE_FILE ...

       rpm {bb1mquerybdes] [b
********

Expected Results:
Should work like 7.3 did, no corruption, real paging, etc.

Additional Information:
currently doing this with putty from a win2k laptop, but I'd imagine is
reproducible from a "normal" screen session - I'll try to confirm that tomorrow,
but it's 5am and I really need to get some sleep sometime soon.
Comment 1 James Manning 2002-07-12 05:21:33 EDT
actually, the more I think about this, I'm not sure this is man's problem, but
it could be screen, could be termcap stuff, whatever - reassigning up to
distribution to let them make that call since i've tagged enough bugs onto bero
and since he'll be catching up once he gets back anyway

[root@localhost root]# rpm -qf $(which man) /etc/termcap
man-1.5j-8
termcap-11.0.1-13
Comment 2 Eido Inoue 2003-02-19 15:56:26 EST
fixed with the man k release + groff in rawhide.

Note You need to log in before you can comment on or make changes to this bug.