Bug 68722 - Cannot send package list to RHN with up2date or rhn_register
Cannot send package list to RHN with up2date or rhn_register
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-12 16:50 EDT by Mike Gahagan
Modified: 2008-05-01 11:38 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-15 15:18:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Gahagan 2002-07-12 16:50:26 EDT
Description of Problem:
When attempting to register a system, all attempts to send package list fail
with various communication errors. Functions such as 'up2date -l' work correctly

Version-Release number of selected component (if applicable):

Stock RHL 7.3 installation

How Reproducible:

always

Steps to Reproduce:
1. install 7.3
2. register w/ rhn_register
3.  

Actual Results:

Registration fails unless user choses to omit the package list.

Expected Results:

RHN should recieve a list of packages

Additional Information:
	
All this is in text mode over an ssh session, X is not installed on the box.
Other systems on the same subnet configured similarly have no problems

rhn_register

A socket error occured (0, error)

up2date -p (traceback)

[root@frogger rhn]# up2date -p
Updating package profile...
Traceback (innermost last):
  File "/usr/sbin/up2date", line 1169, in ?
    main()
  File "/usr/sbin/up2date", line 256, in main
    up2date.updatePackageProfile()
  File "/usr/share/rhn/up2date_client/up2date.py", line 1302, in
updatePackageProfile
    getInstalledPackageList())
  File "/usr/share/rhn/up2date_client/up2date.py", line 434, in doCall
    raise CommunicationError(e.args[1])
up2date_client.up2date.CommunicationError: Error communicating with server.  The
message was:
Error

rpm -qa output:

[root@frogger rhn]# rpm -qa  
mailcap-2.1.9-2
filesystem-2.1.6-2
bzip2-libs-1.0.2-2
db2-2.4.14-10
eject-2.0.12-4
glib2-2.0.1-2
ksymoops-2.4.4-1
mktemp-1.5-14
pcre-3.9-2
perl-DB_File-1.75-34.99.6
reiserfs-utils-3.x.0j-3
newt-0.50.35-1
specspo-7.3-4
bash-2.05a-13
libstdc++-2.96-110
ncurses-5.2-26
ed-0.2-25
gawk-3.1.0-4
grub-0.91-4
openssl-0.9.6b-18
raidtools-1.00.2-1.3
sed-3.02-11
sysklogd-1.4.1-8
dev-3.3-4
tmpwatch-2.8.3-1
vim-common-6.1-2
cracklib-dicts-2.7-15
cyrus-sasl-md5-1.5.24-25
libuser-0.50.2-1
modutils-2.4.14-3
mkbootdisk-1.4.3-1
zlib-1.1.3-25.7
kernel-smp-2.4.18-3
iptables-1.2.5-3
quota-3.03-1
audiofile-0.2.3-1
freetype-2.0.9-2
htmlview-2.0.0-1
libogg-1.0rc3-1
libvorbis-1.0rc3-1
LPRng-3.8.9-3
netpbm-9.24-3
openssh-3.1p1-3
perl-HTML-Tagset-3.03-14
perl-MIME-Base64-2.12-14
perl-libwww-perl-5.63-9
perl-libxml-perl-0.07-14
Omni-foomatic-0.5.1-3
a2ps-4.13b-19
PyXML-0.7-4
watanabe-vf-1.0-5
xinetd-2.3.4-0.8
pspell-0.12.2-8
mc-4.5.55-5
python-xmlrpc-1.5.1-7.x.3
umb-scheme-3.2-21
docbook-dtds-1.0-8
cdrecord-1.10-11
autofs-3.1.7-28
finger-0.17-9
logwatch-2.6-2
nscd-2.2.5-34
pidentd-3.0.14-5
talk-0.17-12
ucd-snmp-4.2.4-3
lockdev-1.0.0-16
wvdial-1.41-16
mutt-1.2.5.1-1
metamail-2.7-28
gd-1.8.4-4
talk-server-0.17-12
samba-client-2.2.3a-6
postgresql-libs-7.2.1-5
postgresql-server-7.2.1-5
mm-1.1.3-4
mod_ssl-2.8.7-4
php-ldap-4.1.2-7
webalizer-2.01_10-1
rdist-6.1.5-16
docbook-style-dsssl-1.76-1
tetex-1.0.7-47
emacs-21.2-2
bc-1.06-8
pax-3.0-1
screen-3.9.11-3
symlinks-1.2-13
xdelta-1.1.3-5
libxml10-1.0.0-8
openssl096-0.9.6-6
autoconf-2.13-17
binutils-2.11.93.0.2-11
cdecl-2.5-22
cups-devel-1.1.14-15
db1-devel-1.85-8
dev86-0.15.5-1
expat-devel-1.95.2-2
gdbm-devel-1.8.0-14
glibc-devel-2.2.5-34
gpm-devel-1.19.3-21
krbafs-devel-1.1.1-1
libogg-devel-1.0rc3-1
libtiff-devel-3.5.7-2
libvorbis-devel-1.0rc3-1
mm-devel-1.1.3-4
njamd-0.9.2-3
parted-devel-1.4.24-3
pcre-devel-3.9-2
glib2-devel-2.0.1-2
python-devel-1.5.2-38
rpm-devel-4.0.4-7x.18
sox-devel-12.17.3-4
texinfo-4.1-1
libpng-devel-1.0.12-2
mtools-3.9.8-2
apache-manual-1.3.23-11
busybox-anaconda-0.60.2-4
diskcheck-1.2-1
ethtool-1.5-1
gd-progs-1.8.4-4
glibc-utils-2.2.5-34
iptraf-2.5.0-3
libsigc++-1.0.3-5
lynx-2.8.4-18
mod_bandwidth-2.0.3-3
mod_throttle-3.1.2-5
MyODBC-2.50.39-4
nc-1.10-11
nss_db-compat-2.2-14
perl-Archive-Tar-0.22-15
perl-Date-Calc-5.0-15
perl-TermReadKey-2.17-14
php-manual-4.1.2-7
postgresql-contrib-7.2.1-5
postgresql-perl-7.2.1-5
pstack-1.1-1
routed-0.17-8
rpmfind-1.7-7
rwho-0.17-11
sysreport-1.3-2
ttcp-1.12-2
w3c-libwww-apps-5.3.2-5
glibc-common-2.2.5-34
indexhtml-7.3-3
man-pages-1.48-2
setup-2.5.12-1
basesystem-7.0-2
bdflush-1.5-17
chkconfig-1.3.5-3
db1-1.85-8
db3-3.3.11-6
e2fsprogs-1.27-3
file-3.37-5
glib-1.2.10-5
hdparm-4.6-1
iputils-20020124-3
losetup-2.11n-12
mingetty-1.00-1
mt-st-0.7-3
parted-1.4.24-3
perl-5.6.1-34.99.6
perl-CPAN-1.59_54-34.99.6
perl-NDBM_File-1.75-34.99.6
pwdb-0.61.2-2
setserial-2.17-5
slang-1.4.5-2
netconfig-0.8.11-7
setuptool-1.8-2
syslinux-1.52-2
libtermcap-2.0.8-28
bzip2-1.0.2-2
iproute-2.4.7-1
groff-1.17.2-12
MAKEDEV-3.3-4
info-4.1-1
diffutils-2.7.2-5
fileutils-4.1-10
findutils-4.1.7-4
grep-2.5.1-1
dhcpcd-1.3.22pl1-7
less-358-24
man-1.5j-6
procmail-3.22-5
psmisc-20.2-2
readline-4.2a-4
rootfiles-7.2-1
console-tools-19990829-40
slocate-2.6-1
tar-1.13.25-4
textutils-2.0.21-1
mount-2.11n-12
time-1.7-16
usbutils-0.9-5
utempter-0.5.2-6
vim-minimal-6.1-2
words-2-18
pam-0.75-32
cyrus-sasl-1.5.24-25
cyrus-sasl-plain-1.5.24-25
openldap-2.0.23-4
passwd-0.67-1
krb5-libs-1.2.4-1
kudzu-0.99.52-1
lilo-21.4.4-14
sendmail-8.11.6-15
usermode-1.53-2
rpm-4.0.4-7x.18
initscripts-6.67-1
kernel-bigmem-2.4.18-3
ipchains-1.3.10-13
kernel-2.4.18-3
pciutils-2.1.9-2
timeconfig-3.2.7-1
anacron-2.3-17
cdparanoia-libs-alpha9.8-8
fortune-mod-1.0-20
gmp-4.0.1-3
htdig-3.2.0-2.011302
libcap-1.10-8
libmng-1.0.3-2
libpng-1.0.12-2
cups-libs-1.1.14-15
libxml-1.8.17-3
libxslt-1.0.15-1
m4-1.4.1-7
mpage-2.5.1-9
nkf-1.92-6
Omni-0.5.1-3
openssh-clients-3.1p1-3
perl-Digest-MD5-2.16-15
perl-HTML-Parser-3.26-2
perl-libxml-enno-1.02-15
perl-Parse-Yapp-1.05-15
perl-URI-1.17-16
perl-XML-Encoding-1.01-9
perl-XML-Parser-2.30-15
perl-XML-Dumper-0.4-12
foomatic-1.1-0.20020313.3
pnm2ppa-1.04-2
psutils-1.17-13
python-1.5.2-38
Distutils-1.0.2-2
4Suite-0.11.1-8
unzip-5.50-2
XFree86-libs-4.2.0-8
Xaw3d-1.5-12
zip-2.3-12
libtool-libs-1.4.2-7
aspell-0.33.7.1-9
libunicode-0.4-6
patch-2.5.4-12
python-clap-1.0.0-3
rpm-python-4.0.4-7x.18
sgml-common-0.6.3-9
guile-1.3.4-19
xml-common-0.6.3-9
openjade-1.3.1-4
cdlabelgen-1.5.0-11
curl-7.9.5-2
mkisofs-1.10-11
bind-utils-9.2.0-8
compat-libstdc++-6.2-2.9.0.16
ftp-0.17-13
libpcap-0.6.2-12
ncftp-3.1.3-3
nmap-2.54BETA31-1
nss_ldap-185-1
pam_krb5-1.55-1
radvd-0.7.1-1
rmt-0.4b27-3
rsh-0.17-5
stunnel-3.22-1
tcp_wrappers-7.6-19
traceroute-1.4a12-2
kernel-utils-2.4-7.4
whois-1.0.10-1
ppp-2.4.1-3
statserial-1.1-27
elinks-0.3.0-1
libesmtp-0.8.4-2
nmh-1.0.4-9
sharutils-4.2.1-9
giftrans-1.12.2-11
finger-server-0.17-9
openssh-server-3.1p1-3
sysstat-4.0.3-2
telnet-server-0.17-20
samba-2.2.3a-6
wu-ftpd-2.6.2-5
perl-DBI-1.21-1
perl-DBD-Pg-1.01-8
postgresql-devel-7.2.1-5
unixODBC-2.2.0-5
hwcrypto-1.0-3
apache-1.3.23-11
mod_perl-1.26-5
mrtg-2.9.17-3
php-imap-4.1.2-7
php-pgsql-4.1.2-7
tux-2.2.5-1
mtr-0.49-1
tripwire-2.3.1-10
tcpdump-3.6.2-12
dialog-0.9a-5
perl-SGMLSpm-1.03ii-4
tetex-fonts-1.0.7-47
tetex-latex-1.0.7-47
w3c-libwww-5.3.2-5
psgml-1.2.3-3
arpwatch-2.1a11-12
dump-0.4b27-3
lv-4.49.4-3
pinfo-0.6.4-4
rsync-2.5.4-2
shapecfg-2.2.12-8
sudo-1.6.5p2-2
tree-1.2-17
vim-enhanced-6.1-2
compat-glibc-6.2-2.1.3.2
libjpeg6a-6a-8
ncurses4-5.0-5
openssl095a-0.9.5a-11
readline2.2.1-2.2.1-4
apache-devel-1.3.23-11
automake-1.4p5-4
autoconf253-2.53-3
bison-1.35-1
bzip2-devel-1.0.2-2
cdparanoia-devel-alpha9.8-8
ctags-5.2.2-2
curl-devel-7.9.5-2
cyrus-sasl-devel-1.5.24-25
db2-devel-2.4.14-10
db3-utils-3.3.11-6
diffstat-1.28-1
e2fsprogs-devel-1.27-3
flex-2.5.4a-23
gdb-5.1.90CVS-5
gettext-0.11.1-2
glibc-kernheaders-2.4-7.14
gcc-2.96-110
gcc-objc-2.96-110
hesiod-devel-3.0.2-18
krb5-devel-1.2.4-1
libao-devel-0.8.2-2
libjpeg-devel-6b-19
libstdc++-devel-2.96-110
libtermcap-devel-2.0.8-28
libtool-1.4.2-7
libuser-devel-0.50.2-1
libxml2-devel-2.4.19-4
ltrace-0.3.10-7
modutils-devel-2.4.14-3
ncurses-devel-5.2-26
openldap-devel-2.0.23-4
pam-devel-0.75-32
patchutils-0.2.11-2
kudzu-devel-0.99.52-1
php-devel-4.1.2-7
audiofile-devel-0.2.3-1
pmake-1.45-4
aspell-devel-0.33.7.1-9
rcs-5.7-15
rpm-build-4.0.4-7x.18
sendmail-devel-8.11.6-15
newt-devel-0.50.35-1
splint-3.0.1.6-2
swig-1.1p5-12
unixODBC-devel-2.2.0-5
zlib-devel-1.1.3-25.7
kernel-source-2.4.18-3
lha-1.14i-4
pam_smb-1.1.6-2
alien-7.24-3
auth_ldap-1.6.0-4
busybox-0.60.2-4
compat-libs-6.2-3
dictd-1.5.5-1
dmalloc-4.8.1-6
elm-2.5.6-2
ftpcopy-0.3.9-1
gcc-chill-2.96-110
glibc-debug-2.2.5-34
glibc-profile-2.2.5-34
gperf-2.7.2-2
imap-2001a-10
kernel-doc-2.4.18-3
libelf-0.7.0-2
libtool-libs13-1.3.5-2
lvm-1.0.3-4
mailman-2.0.9-1
mod_auth_pgsql-0.9.12-2
mod_put-1.3-4
mod_roaming-1.0.2-4
mx-2.0.3-1
mod_auth_mysql-1.11-1
mysql-devel-3.23.49-3
mysqlclient9-3.23.22-6
nss_db-2.2-14
openldap-servers-2.0.23-4
pdksh-5.2.14-16
perl-Bit-Vector-6.1-12
perl-Crypt-SSLeay-0.35-15
perl-DBD-MySQL-1.2219-6
perl-Frontier-RPC-0.06-14
perl-Time-HiRes-1.20-14
php-dbg-4.1.2-7
php-mysql-4.1.2-7
php-snmp-4.1.2-7
postgresql-docs-7.2.1-5
postgresql-odbc-7.2.1-5
postgresql-python-7.2.1-5
psacct-6.3.2-19
python-docs-1.5.2-38
readline41-4.1-10
rpm-perl-4.0.4-7x.18
rpmdb-redhat-7.3-0.20020419
rpmlint-0.38-5
rwall-0.17-10
samba-swat-2.2.3a-6
sendmail-doc-8.11.6-15
tftp-0.28-2
tmake-1.7-3
ucd-snmp-devel-4.2.4-3
vsftpd-1.0.1-5
w3c-libwww-devel-5.3.2-5
zsh-4.0.4-5
hwdata-0.14-1
redhat-logos-1.1.3-1
glibc-2.2.5-34
cracklib-2.7-15
dosfstools-2.8-1
gdbm-1.8.0-14
hesiod-3.0.2-18
mailx-8.1.1-22
net-tools-1.60-4
perl-CGI-2.752-34.99.6
popt-1.6.4-7x.18
shadow-utils-20000902-7
ntsysv-1.3.5-3
termcap-11.0.1-10
crontabs-1.10-1
logrotate-3.6.4-1
cpio-2.4.2-26
at-3.1.8-23
ash-0.3.7-2
gzip-1.3.3-1
procps-2.0.7-12
redhat-release-7.3-1
kbdconfig-1.9.15-2
tcsh-6.10-6
mouseconfig-4.25-1
hotplug-2002_04_01-3
which-2.13-3
authconfig-4.2.8-4
gpm-1.19.3-21
sh-utils-2.0.11-14
mkinitrd-3.3.10-1
SysVinit-2.84-2
util-linux-2.11n-12
apmd-3.0.2-10
lokkit-0.50-8
vixie-cron-3.0.1-64
expat-1.95.2-2
groff-perl-1.17.2-12
libjpeg-6b-19
libtiff-3.5.7-2
libxml2-2.4.19-4
make-3.79.1-8
ntp-4.1.1-1
perl-DateManip-5.40-15
perl-libnet-1.0901-17
perl-Storable-1.0.14-15
perl-XML-Grove-0.46alpha-11
perl-XML-Twig-2.02-9
portmap-4.0-41
alchemist-1.0.23-1
tcl-8.3.3-67
libungif-4.1.0-10
wireless-tools-23-2
gnupg-1.0.6-5
python-popt-0.8.8-7.x.2
rhn_register-2.7.21-7.x.3
up2date-2.7.86-7.x.3
autorun-2.73-1
libao-0.8.2-2
cipe-1.4.5-9
krbafs-1.1.1-1
nfs-utils-0.3.3-5
openldap-clients-2.0.23-4
rdate-1.2-1
sendmail-cf-8.11.6-15
telnet-0.17-20
wget-1.8.1-4
rp-pppoe-3.3-7
fetchmail-5.9.0-5
pine-4.44-7
libusb-0.1.5-3
rsh-server-0.17-5
samba-common-2.2.3a-6
cpp-2.96-110
postgresql-7.2.1-5
asp2php-0.76.2-1
mod_dav-1.0.3-5
php-4.1.2-7
squid-2.4.STABLE6-1.7.2
rarpd-ss981107-9
ucd-snmp-utils-4.2.4-3
docbook-utils-0.6.9-25
linuxdoc-tools-0.9.16-4
tamago-4.0.6-5
lsof-4.51-2
procinfo-18-2
stat-2.5-5
units-1.74-1
glib10-1.0.6-10
openldap12-1.2.13-3
alchemist-devel-1.0.23-1
automake15-1.5-2
byacc-1.9-19
cdrecord-devel-1.10-11
cvs-1.11.1p1-7
db3-devel-3.3.11-6
doxygen-1.2.14-4
gd-devel-1.8.4-4
glib-devel-1.2.10-5
gcc-g77-2.96-110
indent-2.2.7-3
libcap-devel-1.10-8
gcc-c++-2.96-110
libusb-devel-0.1.5-3
lockdev-devel-1.0.0-16
ncompress-4.2.4-28
openssl-devel-0.9.6b-18
pciutils-devel-2.1.9-2
pkgconfig-0.12.0-1
pspell-devel-0.12.2-8
readline-devel-4.2a-4
slang-devel-1.4.5-2
strace-4.4-4
xdelta-devel-1.1.3-5
dos2unix-3.1-10
unix2dos-2.2-15
bash-doc-2.05a-13
db3x-3.2.9-4
ElectricFence-2.2.2-8
gated-3.6-14
glibc-debug-static-2.2.5-34
htdig-web-3.2.0-2.011302
lftp-2.4.9-1
lslk-1.29-3
mod_auth_any-1.0.2-1
mod_python-2.7.6-5
mysql-3.23.49-3
mysql-server-3.23.49-3
ncurses-c++-devel-5.2-26
openssl-perl-0.9.6b-18
perl-BSD-Resource-1.14-11
perl-Devel-Symdump-2.01-15
perl-TimeDate-1.10-14
php-odbc-4.1.2-7
postgresql-jdbc-7.2.1-5
postgresql-tcl-7.2.1-5
python2-docs-2.2-16
rpm2html-1.7-6
rusers-0.17-12
sash-3.4-11
tftp-server-0.28-2
unarj-2.43-10
zebra-0.92a-3
Comment 1 Mike Gahagan 2002-07-15 15:18:40 EDT
Evidently this didn't affect the use of 'up2date -u' as the customer was still
able to apply updates to his packages.

Comment 2 Josef Komenda 2002-10-24 11:47:36 EDT
This bug was fixed some time ago - closing.

Note You need to log in before you can comment on or make changes to this bug.