Bug 68733 - Python seg fault when rebooting
Python seg fault when rebooting
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: rhn-applet (Show other bugs)
7.3
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Veillard
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-12 20:26 EDT by Philip Wyett
Modified: 2007-04-18 12:44 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-08 05:07:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Philip Wyett 2002-07-12 20:26:01 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020513

Description of problem:
python seg fault on reboot. seg fault in /usr/bin/python : process 1337

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
From the Gnome desktop.

1.Click on 'Main Menu' button.
2.Click on 'Log out'.
3.When the dialog box appears select 'Reboot' and click ok.
	

Actual Results:  Error dialog appears stating that a seg fault has occurred in
/usr/bin/python : process 1337. Then the system will reboot without any further
user action.

Expected Results:  It should reboot cleanly, with no error dialogs.

Additional info:
Comment 1 Philip Wyett 2002-07-13 04:18:33 EDT
After further looking this crash i.e. a quick look at '/proc/1337' I found this
is related to the rhn_applet i.e. the rhn update checker which lives on the
Gnome main desktop menu. Once this applet is removed, I experience no more seg
faults when rebooting.
Comment 2 Daniel Veillard 2003-04-08 05:07:56 EDT
Hum, I'm unable to reproduce this on Red Hat 8 or Red Hat 9
following the exact same steps. If you have a way to reproduce
this behaviour on a recent version please reopen the bug
and provide those,

  thanks,

Daniel

Note You need to log in before you can comment on or make changes to this bug.