Bug 68743 - The Firstboot program crashes after initial setup with some X configurations.
The Firstboot program crashes after initial setup with some X configurations.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Public Beta
Classification: Retired
Component: firstboot (Show other bugs)
limbo
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks: 67217
  Show dependency treegraph
 
Reported: 2002-07-13 08:13 EDT by Peter van Egdom
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-15 17:41:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter van Egdom 2002-07-13 08:13:36 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1a) Gecko/20020611

Description of problem:
I'm not sure how to describe my experiences of this bug, but I'll
give it a try. In short, the 'firstboot' procedure/program appears
to have trouble with videocards with 8MB (or less).

...or so it appears at first.

After more trying out, it looks like there's a conflict between
Xconfigurator and Firstboot.

Although I suspect Firstboot is the culprit, looking at the error
it gives (see Additional information).

I looked in Bugzilla for a similar report and found it at Bugzilla
ID # 68386, which is marked as CLOSED, although the last submitter
of comment asks for REOPENING the report.

ps. the first comment of bug # 68386 describes a different problem of
what I'm encountering here myself, so please do not mark this bug
report as a dupe right away.

The person who filed bug # 68386 talks about having a Matrox Millennium G250.

I also have a Matrox card (a Millennium I), so maybe it's a conflict between
Xconfigurator, Firstboot and the Matrox cards.

OK, let's go on.

First of all, the installation of Limbo on my computer (_including_ the
X configuration part), worked out rather good (most of the bugs I encountered 
during installation are reported in Bugzilla, others I'll still have to file a
report in Bugzilla).

During the first-time setup of Limbo on my computer I have successfully set in
Anaconda the resolution to 1024*768*16bit.

(
Here's a fragment of /root/anaconda-ks.cfg

xconfig --card "Matrox Millennium" --videoram 4096 --hsync 30-92
        --vsync 50-150 --resolution 1024x768 --depth 16 --startxonboot
        --defaultdesktop gnome
)

OK, what happened? When I first rebooted this freshly installed Limbo on my
computer, the 'firstboot' program tried to start, but crashed.

I tried to reproduce the problem, by changing "/etc/sysconfig/firstboot" from: 
"RUN_FIRSTBOOT=NO" to "RUN_FIRSTBOOT=YES", but strangely enough the next time
the 'Firstboot' program _did_ work on my computer.

"What the #?!???", I thought.

This time I decided to spend some time reproducing the bug, and I think I found
a way how, well at least with the trick beneath I have reproduced this bug now
twice in a row.

If this procedure also works on non-Matrox cards, I'm not sure.


Version-Release number of selected component (if applicable):

Source RPM: firstboot-0.9.1-3.src.rpm

How reproducible:
Always

Steps to Reproduce:

-01- Turn on computer and start Red Hat Linux Limbo 7.3.92
-02- (Make sure it starts in runlevel 5).
-03- Edit "/etc/sysconfig/firstboot".
     And change RUN_FIRSTBOOT from "NO" to "YES".

-04- While being in runlevel 5 do a "init 3" to go to runlevel 3.
-05- Become root in runlevel 3.
-06- Start "Xconfigurator" and select resolution "1024x768x24 bit".
-07- Type "reboot"

-08- *** computer reboots, starts Limbo and runs Firstboot
         successfully (...this time...) ***

-09- Exit the Firstboot program. (computer will go to GDM).
-10- Change to a virtual terminal (CTRL-ALT-F1).
-11- Become root (su -) and go to runlevel 3 again (init 3).
-12- Start Xconfigurator and set resolution to "1024x768x16 bit".
-13- Modify "/etc/sysconfig/firstboot" again and change
     "RUN_FIRSTBOOT=NO" to "RUN_FIRSTBOOT=YES".

-14- Type "reboot" to start Limbo again.

-15- This time the Firstboot program tries to start a X session, but fails.

(ps. I really have to switch to 24bit, reboot, switch to 16bit,
     reboot, to reproduce the bug...)

(ps. when I configure X with Xconfigurator in 24 bit mode, firstboot starts
     on :0, when I configure X with Xconfigurator in 16 bit mode, firstboot
     APPEARS to start on :1).

      (maybe it then cannot allocate enough VideoRAM?)


Actual Results:  Firstboot crashed while trying to start itself. 
See: Additional Information.




Expected Results:  
Firstboot should start regardless of type of videocard, initial resolution
and/or X settings configured first-time during Anaconda's X configuration.

Additional info:

Here is the info which I quickly grabbed with the mouse (with gpm) on the
virtual terminal during loading of Limbo :

Starting firstboot:
XFree86 Version 4.2.0 (Custom Build: 4.2.0-52) / X Window System
(protocol Version 11, revision 0, vendor release 6600)
Release Date: 23 January 2002
        If the server is older than 6-12 months, or if your card is
        newer than the above date, look for a newer version before
        reporting problems.  (See http://www.XFree86.Org/)
Build Operating System: Linux 2.4.9-e.3smp i686 [ELF]
Build Host: astest

Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
         (++) from command line, (!!) notice, (II) informational,
         (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/XFree86.1.log", Time: Sat Jul 13 12:08:18 2002
(==) Using config file: "/etc/X11/XF86Config-4"
(EE) MGA(0): Static buffer allocation failed, not initializing the DRI
(EE) MGA(0): Need at least 4608 kB video memory at this resolution, bit depth

(--display=:1:1080): Gdk-WARNING **: locale not supported by Xlib

(--display=:1:1080): Gdk-WARNING **: can not set locale modifiers

(firstboot:1068): Gdk-WARNING **: locale not supported by Xlib


(firstboot:1076): Gdk-WARNING **: can not set locale modifiers
Window manager error: Unable to open X display :1

** (--display=:1:1083): WARNING **: CORBA_ORB_destroy: ORB still has 2 refs. in
start_existing_X
about to try
Traceback (most recent call last):
  File "/usr/sbin/firstboot", line 120, in ?
    firstbootWindow.firstbootWindow(wm_pid, doReconfig, doDebug)
AttributeError: 'module' object has no attribute 'firstbootWindow'
                                                           [FAILED]


and here some data from the syslog:

jul 13 12:40:15 localhost firstboot: ** (--display=:1:1083): WARNING **:
CORBA_ORB_destroy: ORB still has 2 refs.
jul 13 12:40:17 localhost firstboot: in start_existing_X
jul 13 12:40:17 localhost firstboot: about to try
jul 13 12:40:17 localhost firstboot: Traceback (most recent call last):
jul 13 12:40:17 localhost firstboot:   File "/usr/sbin/firstboot", line 120, in ?
jul 13 12:40:17 localhost firstboot:     firstbootWindow.firstbootWindow(wm_pid,
doReconfig, doDebug)
jul 13 12:40:17 localhost firstboot: AttributeError: 'module' object has no
attribute 'firstbootWindow'
jul 13 12:40:17 localhost rc: Starting firstboot:  failed
Comment 1 Brent Fox 2002-07-13 18:08:08 EDT
Try setting the resolution to 1024x768x16 bit and then running /etc/X11/X.  My
guess is that the X server will fail to start.  Is that the case?
Comment 2 Warren Togami 2002-07-13 19:04:17 EDT
I reproduced something like this bug.  X failed to start on the actual first
boot, then immediately after started init 5 gdm login screen just fine.  This is
on a ATI Technologies Inc 3D Rage Pro AGP 1X/2X (rev 5c).  The errors before the
CORBA_ORB_destroy line are different, but after that point it is the same as above.

Here are the XFree86 errors before the CORBA_ORB_destroy line:
(==) Using config file: "/etc/X11/XF86Config"
starting version (version 1.2.0), pid 1302 user 'root'
Resolved address "xml:radonly:/etc/gconf/gconf.xml.mandatory" to a read-only
config source at position 0
Resolved address "xml:readwrite:/root/.gconf" to a writable config source at
position 1
Resolved address "xml:readonly:/etc/gconf/gconf.xml.defaults" to a read-only
config source at position 2
Unable to open saved state file '/root.gconfd/saved_state': No such file or
directory
Window manager error: Unable to open X display :1

** (--display:1:1299): WARNING **: CORBA_ORB_destroy: ORB still has 2 refs.
Comment 3 Peter van Egdom 2002-07-14 11:40:38 EDT
In response to the comment by bfox@redhat.com @ 2002-07-13 18:08:08 :

Starting the X server by running "/etc/X11/X" in runlevel 3 works without
any problem.

I tried several combinations of resolutions & color depth including :

 - 1280 x 1024 x  8 bit
 - 1024 x 768  x 15 bit
 - 1024 x 768  x 16 bit
 - 1024 x 768  x 24 bit

and each time X succesfully started by running "/etc/X11/X".

In fact, I can use this machine without a hitch in X (aside from the 
known problems in Bugzilla).

I think it is really the firstboot program/procedure that does something
odd somewhere.

When the firstboot program/procedure tries to start on display :1 (well,
that looks like it's doing) it crashes after starting and generates the
error mentioned above. After this, the initialisation of Limbo immediately
jumps to X (display :0) and displays the GNOME Display Manager screen.

The comment by warren@togami.com speaks of an ATI card, so possibly
more videocards besides Matrox and ATI will have this problem.


Comment 4 Brent Fox 2002-07-15 10:55:38 EDT
Look in your /var/log/messages file.  Is there any traceback info from firstboot?
Comment 5 Peter van Egdom 2002-07-15 17:04:02 EDT
Included beneath this comment are two entries from my "/var/log/messages" file,
which might be useful.

The first entry (from July 13, 2002) shows a successfull startup of Firstboot
(as proven by the stopping and starting of the NTP service, triggered by the
first screen - the clock synchronisation setting - of Firstboot. 

This first entry was in 1024x768x24 bit modus (as hinted by X complaining
about not having enough (9 MB) video ram).

The second entry (from July 14, 2002) shows a failed startup of Firstboot in
1024x768x16 bit (as hinted by X complaining about needing 4.5 MB video ram).

So, the main question is : why does firstboot work in 1024x768x24 mode and not
in 1024x768x16 bit mode. I did a compare of the XF86config file from the 24
bit configuration and from the 16 bit configuration, but the only difference
was the lines stating the color depth (the line with "Depth 16" instead of
"Depth 24"...)



jul 13 12:00:12 localhost firstboot: (EE)
jul 13 12:00:12 localhost firstboot: MGA(0): Static buffer allocation failed,
not initializing the DRI
jul 13 12:00:12 localhost firstboot: (EE) MGA(0): Need at least 9216 kB video
memory at this resolution, bit depth
jul 13 12:00:17 localhost firstboot:
jul 13 12:00:17 localhost firstboot: (--display=:1:1080): Gdk-WARNING **: locale
not supported by Xlib
jul 13 12:00:17 localhost firstboot:
jul 13 12:00:17 localhost firstboot: (--display=:1:1080): Gdk-WARNING **: can
not set locale modifiers
jul 13 12:00:17 localhost firstboot:
jul 13 12:00:17 localhost firstboot: (--display=:1:1080): Gtk-WARNING **:
Whoever translated default:LTR did so wrongly.
jul 13 12:00:17 localhost firstboot:
jul 13 12:00:18 localhost firstboot:
jul 13 12:00:18 localhost firstboot: (firstboot:1076): Gdk-WARNING **: locale
not supported by Xlib
jul 13 12:00:18 localhost firstboot:
jul 13 12:00:18 localhost firstboot:
jul 13 12:00:18 localhost firstboot: (firstboot:1076): Gdk-WARNING **: locale
not supported by Xlib
jul 13 12:00:18 localhost firstboot:
jul 13 12:00:18 localhost firstboot: (firstboot:1076): Gdk-WARNING **: can not
set locale modifiers
jul 13 12:00:18 localhost firstboot:
jul 13 12:00:18 localhost firstboot: (firstboot:1076): Gtk-WARNING **: Whoever
translated default:LTR did so wrongly.
jul 13 12:00:18 localhost firstboot:
jul 13 12:00:21 localhost firstboot: Window manager warning:
jul 13 12:00:21 localhost firstboot: Failed to a open connection to a session
manager, so window positions will not be saved: SESSION_MANAGER environment
variable not defined
jul 13 12:00:54 localhost firstboot: Shutting down ntpd:
jul 13 12:00:55 localhost firstboot: ^[[60G
jul 13 12:00:55 localhost firstboot: [  ^[[0;32mOK
jul 13 12:00:55 localhost firstboot:
jul 13 12:00:55 localhost firstboot: Starting ntpd:
jul 13 12:00:55 localhost firstboot: ^[[60G
jul 13 12:00:55 localhost firstboot: [  ^[[0;32mOK
jul 13 12:00:55 localhost firstboot:


<snip>
<snip>
<snip>

<snip>
<snip>

jul 14 13:44:40 localhost firstboot: MGA(0): Static buffer allocation failed,
not initializing the DRI
jul 14 13:44:40 localhost firstboot: (EE) MGA(0): Need at least 4608 kB video
memory at this resolution, bit depth
jul 14 13:44:45 localhost firstboot:
jul 14 13:44:45 localhost firstboot: (firstboot:1068): Gdk-WARNING **: locale
not supported by Xlib
jul 14 13:44:45 localhost firstboot:
jul 14 13:44:45 localhost firstboot: (firstboot:1068): Gdk-WARNING **: can not
set locale modifiers
jul 14 13:44:46 localhost firstboot:
jul 14 13:44:46 localhost firstboot: (--display=:1:1079): Gdk-WARNING **: locale
not supported by Xlib
jul 14 13:44:46 localhost firstboot:
jul 14 13:44:46 localhost firstboot: (--display=:1:1079): Gdk-WARNING **: can
not set locale modifiers
jul 14 13:44:52 localhost firstboot: Window manager error: Unable to open X
display :1
jul 14 13:44:52 localhost firstboot:
jul 14 13:44:52 localhost firstboot: ** (--display=:1:1079): WARNING **:
CORBA_ORB_destroy: ORB still has 2
refs.
jul 14 13:44:52 localhost firstboot: in start_existing_X
jul 14 13:44:52 localhost firstboot: about to try
jul 14 13:44:52 localhost firstboot: Traceback (most recent call last):
jul 14 13:44:52 localhost firstboot:   File "/usr/sbin/firstboot", line 120, in ?
jul 14 13:44:52 localhost firstboot:     firstbootWindow.firstbootWindow(wm_pid,
doReconfig, doDebug)
jul 14 13:44:52 localhost firstboot: AttributeError: 'module' object has no
attribute 'firstbootWindow'
jul 14 13:44:52 localhost rc: Starting firstboot:  failed
Comment 6 Peter van Egdom 2002-07-31 13:52:31 EDT
I installed Red Hat Linux - Limbo 7.3.93 (beta 2) from scratch on my HP PC
and noticed this bug is still present in this beta version of Linux.

The same error (described above) occured (Firstboot crashed when it starts for
the very first time, and when it does that it goes immediately to GDM).


Here is the info from "/var/log/messages" :

jul 30 22:54:16 limbo-pc firstboot:
jul 30 22:54:16 limbo-pc firstboot: XFree86 Version 4.2.0 (Red Hat Linux
    release: 4.2.0-56) / X Window System
jul 30 22:54:16 limbo-pc firstboot: (protocol Version 11, revision 0, vendor
    release 6600)
jul 30 22:54:16 limbo-pc firstboot: Release Date: 23 January 2002
jul 30 22:54:16 limbo-pc firstboot: ^IIf the server is older than 6-12 months,
    or if your card is
jul 30 22:54:16 limbo-pc firstboot: ^Inewer than the above date, look for a
    newer version before
jul 30 22:54:16 limbo-pc firstboot: ^Ireporting problems.  (See
    http://www.XFree86.Org/)
jul 30 22:54:16 limbo-pc firstboot: Build Operating System: Linux
    2.4.17-0.13smp i686 [ELF]
jul 30 22:54:16 limbo-pc firstboot: Build Host: daffy.perf.redhat.com
jul 30 22:54:16 limbo-pc firstboot:
jul 30 22:54:16 limbo-pc firstboot: Module Loader present
jul 30 22:54:16 limbo-pc firstboot: Markers: (--) probed, (**) from config
    file, (==) default setting,
jul 30 22:54:16 limbo-pc firstboot:          (++) from command line, (!!)
    notice, (II) informational,
jul 30 22:54:16 limbo-pc firstboot:          (WW) warning, (EE) error, (NI) not
    implemented, (??) unknown.
jul 30 22:54:16 limbo-pc firstboot: (==) Log file: "/var/log/XFree86.1.log",
    Time: Tue Jul 30 22:54:16 2002
jul 30 22:54:16 limbo-pc firstboot: (==) Using config file:
    "/etc/X11/XF86Config"
jul 30 22:54:25 limbo-pc firstboot: --display=:1: Fatal IO error 104
    (Verbinding gesloten door communicatiepartner) on X server :1.
jul 30 22:54:25 limbo-pc firstboot:
jul 30 22:54:25 limbo-pc firstboot: ** (--display=:1:901): WARNING **:
    CORBA_ORB_destroy: ORB still has 2 refs.
jul 30 22:54:32 limbo-pc firstboot: in start_existing_X
jul 30 22:54:32 limbo-pc firstboot: Traceback (most recent call last):
jul 30 22:54:32 limbo-pc firstboot:   File "/usr/sbin/firstboot", line 120,
    in ?
jul 30 22:54:32 limbo-pc firstboot:     firstbootWindow.firstbootWindow(wm_pid,
    doReconfig, doDebug)
jul 30 22:54:32 limbo-pc firstboot: AttributeError: 'module' object has no
    attribute 'firstbootWindow'
jul 30 22:54:32 limbo-pc rc: Starting firstboot:  failed

Comment 7 Brent Fox 2002-08-01 15:36:25 EDT
I've just seen this on someone's test machine here at work, so I've got a
reproducible test case.  I will investigate further.  

Just out of curiosity, what kind of machine is this?  (CPU speed, video card, etc.)
Comment 8 Warren Togami 2002-08-01 16:56:27 EDT
My machine: some type of Gateway 2000 server
Video: ATI Technologies Inc 3D Rage Pro AGP 1X/2X (rev 5c)
Chipset: i440BX
CPU: Pentium II 450MHz
RAM: 384MB PC100 SDRAM
Comment 9 Peter van Egdom 2002-08-03 05:29:30 EDT
Unfortunately, I cannot test Limbo beta 2 on my other machine
(a Dell Pentium II / 233, Matrox Millennium 4MB, 96 MB RAM)
(on which I had seen the firstboot bug _also_ with Limbo beta 1) at the moment,
because I use this Dell machine as a NFS / FTP server for testing material for
another showstopper bug #70573.

OK, here's some info from the machine which has troubles with firstboot on
Limbo beta 2 :

Machine   : HP Vectra VL 400 DT (with no additional hardware, just as it is
            delivered by Hewlett-Packard).
Videocard : Intel(R) 815 Chipset
CPU       : Pentium III (Coppermine) / 733 mhz
RAM       : 128 MB


Some information I found in "/var/log/XFree86.0.log" :

used module by XFree86 : I810: 
Driver for Intel i810 chipset: i810, i810-dc100, i810e, i815, i830M, 845G



And some detailed information from "lspci" :

[root@limbo-pc proc]# lspci -v |more
00:00.0 Host bridge: Intel Corp. 82815 815 Chipset Host Bridge and Memory
Controller Hub (rev 02)
        Subsystem: Intel Corp. 82815 815 Chipset Host Bridge and Memory
Controller Hub
        Flags: bus master, fast devsel, latency 0
        Capabilities: [88] #09 [f104]

00:02.0 VGA compatible controller: Intel Corp. 82815 CGC [Chipset Graphics
Controller] (rev 02) (prog-if 00 [VGA])
        Subsystem: Hewlett-Packard Company: Unknown device 1245
        Flags: bus master, 66Mhz, medium devsel, latency 0, IRQ 10
        Memory at f0000000 (32-bit, prefetchable) [size=64M]
        Memory at ec000000 (32-bit, non-prefetchable) [size=512K]
        Capabilities: [dc] Power Management version 2

00:1e.0 PCI bridge: Intel Corp. 82801AA PCI Bridge (rev 02) (prog-if 00 [Normal
decode])
        Flags: bus master, fast devsel, latency 0
        Bus: primary=00, secondary=01, subordinate=01, sec-latency=32
        I/O behind bridge: 00002000-00002fff
        Memory behind bridge: ec100000-ec1fffff

00:1f.0 ISA bridge: Intel Corp. 82801AA ISA Bridge (LPC) (rev 02)
        Flags: bus master, medium devsel, latency 0

00:1f.1 IDE interface: Intel Corp. 82801AA IDE (rev 02) (prog-if 80 [Master])
        Subsystem: Intel Corp. 82801AA IDE
        Flags: bus master, medium devsel, latency 0
        [virtual] I/O ports at 01f0
        [virtual] I/O ports at 03f4
        [virtual] I/O ports at 0170
        [virtual] I/O ports at 0374
        I/O ports at 1800 [size=16]

00:1f.2 USB Controller: Intel Corp. 82801AA USB (rev 02) (prog-if 00 [UHCI])
        Subsystem: Intel Corp. 82801AA USB
        Flags: bus master, medium devsel, latency 0, IRQ 11
        I/O ports at 1820 [size=32]

00:1f.3 SMBus: Intel Corp. 82801AA SMBus (rev 02)
        Subsystem: Intel Corp. 82801AA SMBus
        Flags: medium devsel, IRQ 9
        I/O ports at 1810 [size=16]

00:1f.5 Multimedia audio controller: Intel Corp. 82801AA AC'97 Audio (rev 02)
        Subsystem: Hewlett-Packard Company: Unknown device 1249
        Flags: medium devsel, IRQ 9
        I/O ports at 1200 [disabled] [size=256]
        I/O ports at 1300 [disabled] [size=64]

01:04.0 Ethernet controller: 3Com Corporation 3c905C-TX/TX-M [Tornado] (rev 78)
        Subsystem: Hewlett-Packard Company: Unknown device 1246
        Flags: bus master, medium devsel, latency 80, IRQ 5
        I/O ports at 2000 [size=128]
        Memory at ec100000 (32-bit, non-prefetchable) [size=128]
        Expansion ROM at <unassigned> [disabled] [size=128K]
        Capabilities: [dc] Power Management version 2
Comment 10 Brent Fox 2002-08-13 16:52:47 EDT
I'm pretty sure that this is the race condition bug that I believe has been
fixed in firstboot-0.9.9-7.  If you see this behavior occur in 0.9.9-7 or later,
please reopen this bug.  I believe that this is a dupe of bug 68504
Comment 11 Warren Togami 2002-08-13 17:20:05 EDT
firstboot-0.9.9-1 here, and I'm still getting this error consistently:

Starting firstboot:  Window manager error: Unable to open X display :1

** (--display=:1:3259): WARNING **: CORBA_ORB_destroy: ORB still has 2 refs.
/usr/bin/X11/xsetroot:  unable to open display ':1'
xrdb: No such file or directory
xrdb: Can't open display ':1'
Window manager error: Unable to open X display :1

** (--display=:1:3264): WARNING **: CORBA_ORB_destroy: ORB still has 2 refs.
/usr/bin/X11/xsetroot:  unable to open display ':1'
xrdb: No such file or directory
xrdb: Can't open display ':1'
in start_existing_X
Starting X using existing XF86Config
Traceback (most recent call last):
  File "/usr/sbin/firstboot", line 126, in ?
    firstbootWindow.firstbootWindow(wm_pid, doReconfig, doDebug)
AttributeError: 'module' object has no attribute 'firstbootWindow'
in start_existing_X
Traceback (most recent call last):
  File "/usr/sbin/firstboot", line 126, in ?
    firstbootWindow.firstbootWindow(wm_pid, doReconfig, doDebug)
AttributeError: 'module' object has no attribute 'firstbootWindow'
                                                           [FAILED]
Comment 12 Warren Togami 2002-08-13 17:44:59 EDT
firstboot-0.9.9-4 appears to do nothing at the console and says [ OK ], but
dumps that same stuff into /var/log/messages.
Comment 13 Warren Togami 2002-08-13 17:56:05 EDT
Oops, sorry misread your last post.  Thought it said 0.9.7.  version 0.9.9-7 is
not yet available in Rawhide.
Comment 14 Peter van Egdom 2002-08-13 18:27:24 EDT
Upgraded to firstboot-0.9.9-4 on two of my systems.
(as told by Warren I did not see a firstboot >= 0.9.9-7).

With the firstboot from RH Limbo beta 2 both of these 2 systems did not
work at all.

With RAWHIDE's firstboot 0.9.9-4 one of my systems (with a Matrox card) did
start, but crashed when selecting the "Register this system" button.

This is the entry from syslog on the Matrox system :

Aug 13 23:29:05 localhost firstboot: The program 'firstboot' received an X
Window System error.
Aug 13 23:29:05 localhost firstboot: This probably reflects a bug in the program.
Aug 13 23:29:05 localhost firstboot: The error was 'BadIDChoice (invalid
resource ID chosen for this connection)'.
Aug 13 23:29:05 localhost firstboot:   (Details: serial 6776 error_code 14
request_code 53 minor_code 0)
Aug 13 23:29:05 localhost firstboot:   (Note to programmers: normally, X errors
are reported asynchronously;
Aug 13 23:29:05 localhost firstboot:    that is, you will receive the error a
while after causing it.
Aug 13 23:29:05 localhost firstboot:    To debug your program, run it with the
--sync command line
Aug 13 23:29:05 localhost firstboot:    option to change this behavior. You can
then get a meaningful
Aug 13 23:29:05 localhost firstboot:    backtrace from your debugger if you
break on the gdk_x_error() function.)
Aug 13 23:29:05 localhost firstboot: Screen width is 1024



But... on the other system - the HP with the Intel 815 graphics card, 
firstboot still crashed on startup , but with a different error message in
syslog than before :


aug 13 23:46:25 limbo-hp firstboot:
aug 13 23:46:25 limbo-hp firstboot: (--display=:1:781): Gtk-WARNING **: Whoever
translated default:LTR did so wrong
y.
aug 13 23:46:25 limbo-hp firstboot:
aug 13 23:46:27 limbo-hp firstboot:
aug 13 23:46:27 limbo-hp firstboot: (firstboot:779): Gtk-WARNING **: Whoever
translated default:LTR did so wrongly.
aug 13 23:46:27 limbo-hp firstboot:
aug 13 23:46:36 limbo-hp firstboot: Screen width is 1024
aug 13 23:46:36 limbo-hp firstboot: ['nl_NL.UTF-8', 'nl_NL', 'nl',
'en_US.UTF-8', 'en_US', 'en']
aug 13 23:46:36 limbo-hp firstboot: Traceback (most recent call last):
aug 13 23:46:36 limbo-hp firstboot:   File "/usr/sbin/firstboot", line 127, in ?
aug 13 23:46:36 limbo-hp firstboot:     firstbootWindow.firstbootWindow(wm_pid,
doReconfig, doDebug)
aug 13 23:46:36 limbo-hp firstboot:   File
"/usr/share/firstboot/firstbootWindow.py", line 88, in __init__
aug 13 23:46:36 limbo-hp firstboot:     exec(cmd)
aug 13 23:46:36 limbo-hp firstboot:   File "<string>", line 2, in ?
aug 13 23:46:36 limbo-hp firstboot:   File
"/usr/share/firstboot/modules/soundcard_gui.py", line 56, in __init__
aug 13 23:46:36 limbo-hp firstboot:     self.notebook =
self.soundcardPage.getNotebook()
aug 13 23:46:36 limbo-hp firstboot: AttributeError: childWindow instance has no
attribute 'getNotebook'
aug 13 23:46:37 limbo-hp rc: Starting firstboot:  succeeded


Of course, as soon as the new firstboot is in RAWHIDE, I'll try again.
Comment 15 Peter van Egdom 2002-08-15 17:41:54 EDT
Upgraded today to RAWHIDE's "firstboot-0.9.9-12" on my HP with the
Intel 815 graphics card.

Unfortunately Firstboot still crashes. 
It tries to start on DISPLAY :0, but fails.

After it has crashed, GDM shows up on DISPLAY :1, leaving an X Window
Session ('grey dotted background with X mouse cursor') open on DISPLAY :0.

This is the entry from my syslog :

aug 15 22:14:26 limbo-hp firstboot: XFree86 Version 4.2.0 (Red Hat Linux
release: 4.2.0-56) / X Window System
aug 15 22:14:26 limbo-hp firstboot: (protocol Version 11, revision 0, vendor
release 6600)
aug 15 22:14:26 limbo-hp firstboot: Release Date: 23 January 2002
aug 15 22:14:26 limbo-hp firstboot: ^IIf the server is older than 6-12 months,
or if your card is
aug 15 22:14:26 limbo-hp firstboot: ^Inewer than the above date, look for a
newer version before
aug 15 22:14:26 limbo-hp firstboot: ^Ireporting problems.  (See
http://www.XFree86.Org/)
aug 15 22:14:26 limbo-hp firstboot: Build Operating System: Linux 2.4.17-0.13smp
i686 [ELF]
aug 15 22:14:26 limbo-hp firstboot: Build Host: daffy.perf.redhat.com
aug 15 22:14:26 limbo-hp firstboot:
aug 15 22:14:26 limbo-hp firstboot: Module Loader present
aug 15 22:14:26 limbo-hp firstboot: Markers: (--) probed, (**) from config file,
(==) default setting,
aug 15 22:14:26 limbo-hp firstboot:          (++) from command line, (!!)
notice, (II) informational,
aug 15 22:14:26 limbo-hp firstboot:          (WW) warning, (EE) error, (NI) not
implemented, (??) unknown.
aug 15 22:14:27 limbo-hp firstboot: (==) Log file: "/var/log/XFree86.1.log",
Time: Thu Aug 15 22:14:26 2002
aug 15 22:14:27 limbo-hp firstboot: (==) Using config file: "/etc/X11/XF86Config"
aug 15 22:14:39 limbo-hp firstboot:
aug 15 22:14:39 limbo-hp firstboot: (--display=:1:782): Gtk-WARNING **: Whoever
translated default:LTR did so wrongly.
aug 15 22:14:39 limbo-hp firstboot:
aug 15 22:14:41 limbo-hp firstboot:
aug 15 22:14:41 limbo-hp firstboot: (firstboot.py:780): Gtk-WARNING **: Whoever
translated default:LTR did so wrongly.
aug 15 22:14:41 limbo-hp firstboot:
aug 15 22:14:43 limbo-hp firstboot: Window manager warning: Failed to a open
connection to a session manager, so window positions will not be saved:
SESSION_MANAGER environment variable not defined
aug 15 22:14:45 limbo-hp firstboot: Screen width is 1024
aug 15 22:14:45 limbo-hp firstboot: ['nl_NL.UTF-8', 'nl_NL', 'nl',
'en_US.UTF-8', 'en_US', 'en']
aug 15 22:14:45 limbo-hp firstboot: Traceback (most recent call last):
aug 15 22:14:45 limbo-hp firstboot:   File "/usr/share/firstboot/firstboot.py",
line 136, in ?
aug 15 22:14:45 limbo-hp firstboot:     firstbootWindow.firstbootWindow(wm_pid,
doReconfig, doDebug)
aug 15 22:14:45 limbo-hp firstboot:   File
"/usr/share/firstboot/firstbootWindow.py", line 88, in __init__
aug 15 22:14:45 limbo-hp firstboot:     exec(cmd)
aug 15 22:14:45 limbo-hp firstboot:   File "<string>", line 2, in ?
aug 15 22:14:45 limbo-hp firstboot:   File
"/usr/share/firstboot/modules/soundcard_gui.py", line 56, in __init__
aug 15 22:14:45 limbo-hp firstboot:     self.notebook =
self.soundcardPage.getNotebook()
aug 15 22:14:45 limbo-hp firstboot: AttributeError: childWindow instance has no
attribute 'getNotebook'
aug 15 22:14:46 limbo-hp rc: Starting firstboot:  succeeded
[root@limbo-hp log]#
Comment 16 Peter van Egdom 2002-08-21 13:59:44 EDT
Installed Red Hat Linux 'null' from scratch on the :

- Dell / PII/233 / Matrox Millennium / 96 MB RAM.
- HP Vectra VL 400 / Pentium III 500 mhz / 128 MB RAM / Intel 815 

and so far it appears Firstboot is working correctly in Red Hat Linux 'null'.

Thank you!

I'll close the call.

Note You need to log in before you can comment on or make changes to this bug.