Bug 68765 - [HIG] Confusing Menu Layout
[HIG] Confusing Menu Layout
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: redhat-menus (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-13 17:40 EDT by Allen A George
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-08 17:47:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Allen A George 2002-07-13 17:40:05 EDT
The default menu layout is quite confusing

Here are some of the problems that I noted:

1.  Nautilus/File Manager does not seem to exist on the menus!  Nautilus is
installed on the system however, since I started it from the command line.

2.  The All Applications menu is very confusing.

I believe all applications includes applications from KDE and GNOME.  Is there
any problem in removing this menu and merging its contents into the base menu
system?  It would be cleaner and pose less problems for new users.

If not, perhaps a Menu--->KDE Section?

For example.  There is a:

Menu--->System Tools and a Menu--->All Applications--->System Tools

The differences are:

CUPS Printer Config (should this not be in  Menu--->System Tools ?)
Desktop Switching Tool (perhaps a Menu--->Desktop Tools section)
Configuration Editor (perhaps a Menu--->Desktop Tools Section)
About Myself (I'm not sure where this goes)

This same 2/3 item difference occurs in most of the Menu--->All Applications
menu items.

A new user would be hard pressed to understand what the difference is between
Menu--->Any menu item and Menu--->All Applications--->Same Menu Items
Comment 1 Havoc Pennington 2002-07-13 18:01:34 EDT
This is a dup/known issue. Limbo doesn't contain a serious attempt at good menus.

The All Applications split is because for most users they need no more than 7-10
items per submenu, but other users want to see all the junk they have installed.
Removing All Applications probably means just leaving a lot of things out entirely.
Comment 2 Havoc Pennington 2003-01-08 17:47:37 EST
I think most of this is addressed in rawhide. If stuff remains when beta2 comes
out, please file one bug per issue for tracking.

Note You need to log in before you can comment on or make changes to this bug.