Bug 68778 - [patch] SpinButton not accepting valid input.
Summary: [patch] SpinButton not accepting valid input.
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux Beta
Classification: Retired
Component: redhat-config-users   
(Show other bugs)
Version: beta3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 67217
TreeView+ depends on / blocked
 
Reported: 2002-07-14 01:39 UTC by Brent Fox
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-20 13:08:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This patch fixes it for me. (1.85 KB, patch)
2002-08-19 17:29 UTC, Tim Waugh
no flags Details | Diff

Description Brent Fox 2002-07-14 01:39:17 UTC
[root@bfox src]# ./redhat-config-users.py
Traceback (most recent call last):
  File "./userWindow.py", line 256, in on_userWin_ok_button_clicked
    self.userWinReset()
  File "./userWindow.py", line 90, in userWinReset
    self.uidSpinButton.set_value(500)
TypeError: argument 2 must be list, not long


The value '500' is not a long.  Also, a SpinButton should not be expecting a
list.  What gives?

Comment 1 Karsten Hopp 2002-08-13 13:26:44 UTC
I couldn't reproduce this with todays snapshot. Can you please verify ?

Comment 2 Karsten Hopp 2002-08-13 14:14:47 UTC
Correction, I can reproduce this now. 
It happens when you add a user to an already existing group: 
- add user with its own group 
- remove user ( group still exists) 
- add same user again 


Comment 3 Tim Waugh 2002-08-19 17:29:14 UTC
Please try the attached patch.

Comment 4 Tim Waugh 2002-08-19 17:29:51 UTC
Created attachment 71465 [details]
This patch fixes it for me.

Comment 5 Brent Fox 2002-08-19 19:06:40 UTC
Patch applied.  That seems to fix it.  Thank you very much.  :)

Should be fixed in 1.1-14.  QA, please verify.

Comment 6 Jay Turner 2002-08-23 03:01:43 UTC
Fix confirmed with redhat-config-users-1.1-15.


Note You need to log in before you can comment on or make changes to this bug.