Bug 68779 - Bunch of permissions wrong when verifying privoxy; also shouldn't ship with rc.d links
Bunch of permissions wrong when verifying privoxy; also shouldn't ship with r...
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: privoxy (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Karsten Hopp
:
: 69224 (view as bug list)
Depends On:
Blocks: 67217
  Show dependency treegraph
 
Reported: 2002-07-13 21:53 EDT by Jonathan Kamens
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-14 21:12:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2002-07-13 21:53:51 EDT
After installing privoxy-2.9.15-4, I get lots of errors when verifying it:

.....UG.   /etc/privoxy
SM5....T c /etc/privoxy/config
.....UGT c /etc/privoxy/default.action
.....UG. c /etc/privoxy/default.filter
.....UG. c /etc/privoxy/standard.action
.....UG.   /etc/privoxy/templates
.....UG. c /etc/privoxy/templates/blocked
.....UG. c /etc/privoxy/templates/cgi-error-404
.....UG. c /etc/privoxy/templates/cgi-error-bad-param
.....UG. c /etc/privoxy/templates/cgi-error-disabled
.....UG. c /etc/privoxy/templates/cgi-error-file
.....UG. c /etc/privoxy/templates/cgi-error-file-read-only
.....UG. c /etc/privoxy/templates/cgi-error-modified
.....UG. c /etc/privoxy/templates/cgi-error-parse
.....UG. c /etc/privoxy/templates/cgi-style.css
.....UG. c /etc/privoxy/templates/connect-failed
.....UG. c /etc/privoxy/templates/default
.....UG. c /etc/privoxy/templates/edit-actions-add-url-form
.....UG. c /etc/privoxy/templates/edit-actions-for-url
.....UG. c /etc/privoxy/templates/edit-actions-for-url-filter
.....UG. c /etc/privoxy/templates/edit-actions-list
.....UG. c /etc/privoxy/templates/edit-actions-list-button
.....UG. c /etc/privoxy/templates/edit-actions-list-section
.....UG. c /etc/privoxy/templates/edit-actions-list-url
.....UG. c /etc/privoxy/templates/edit-actions-remove-url-form
.....UG. c /etc/privoxy/templates/edit-actions-url-form
.....UG. c /etc/privoxy/templates/mod-local-help
.....UG. c /etc/privoxy/templates/mod-support-and-service
.....UG. c /etc/privoxy/templates/mod-title
.....UG. c /etc/privoxy/templates/mod-unstable-warning
.....UG. c /etc/privoxy/templates/no-such-domain
.....UG. c /etc/privoxy/templates/show-request
.....UG. c /etc/privoxy/templates/show-status
.....UG. c /etc/privoxy/templates/show-status-file
.....UG. c /etc/privoxy/templates/show-url-info
.....UG. c /etc/privoxy/templates/show-version
.....UG. c /etc/privoxy/templates/toggle
.....UG. c /etc/privoxy/templates/toggle-mini
.....UG. c /etc/privoxy/templates/untrusted
.....UG. c /etc/privoxy/trust
SM5....T c /etc/privoxy/user.action
missing    /etc/rc.d/rc0.d/K09privoxy
missing    /etc/rc.d/rc1.d/K09privoxy
missing    /etc/rc.d/rc2.d/S84privoxy
missing    /etc/rc.d/rc4.d/K09privoxy
missing    /etc/rc.d/rc6.d/K09privoxy

The "UG" errors are because the package explicitly changes permissions on
various directories to privoxy.privoxy in the postinstall script.  These files
should be shipped privoxy.privoxy in the RPM, to avoid these errors.

The missing files in /etc/rc.d are because privoxy ships with thsoe files in the
RPM, which it shouldn't.  Instead, it should use chkconfig as appropriate in the
postinstall script to set up the right links.
Comment 1 Karsten Hopp 2002-07-15 04:39:11 EDT
already fixed in -5
Comment 2 Karsten Hopp 2002-07-23 10:36:16 EDT
*** Bug 69224 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.