Bug 68807 - additional services for logwatch
additional services for logwatch
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: logwatch (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-14 13:32 EDT by Jay Berkenbilt
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-08 11:45:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to secure.conf to exclude Pluto and stunnel (483 bytes, patch)
2002-07-14 13:33 EDT, Jay Berkenbilt
no flags Details | Diff
freeswan configuration file and script (3.93 KB, patch)
2002-07-14 13:35 EDT, Jay Berkenbilt
no flags Details | Diff
stunnel configuration file and script (2.95 KB, patch)
2002-07-14 13:36 EDT, Jay Berkenbilt
no flags Details | Diff

  None (edit)
Description Jay Berkenbilt 2002-07-14 13:32:55 EDT
Description of Problem:

I am submitting two scripts for logwatch that capture log messages from services
that RedHat either does not provide or does not use by default.  Their inclusion
does not interfere with anything that RedHat does offer, however, and also makes
life a little easier for administrators who include these services on a RedHat
system.  The services in question are stunnel and FreeS/WAN.

I have also submitted these suggestions to the logwatch maintainers.


Version-Release number of selected component (if applicable):

logwatch-2.6-2

My change involves adding two scripts and two configuration files, and patching
secure.conf to omit lines about those services from the general secure log
output.  Note that for this to work properly, my one-line patch to secure from
bug 68806 must be applied.  Otherwise, the exclusion of "pluto" won't match
because it appears as Pluto in the actual log.

Three patches are attached: the secure.conf patch, and one patch each for
stunnel and freeswan.
Comment 1 Jay Berkenbilt 2002-07-14 13:33:27 EDT
Created attachment 65309 [details]
patch to secure.conf to exclude Pluto and stunnel
Comment 2 Jay Berkenbilt 2002-07-14 13:35:06 EDT
Created attachment 65310 [details]
freeswan configuration file and script
Comment 3 Jay Berkenbilt 2002-07-14 13:36:10 EDT
Created attachment 65311 [details]
stunnel configuration file and script
Comment 4 Elliot Lee 2002-08-08 11:45:34 EDT
Probably will just get these from upstream eventually.
Comment 5 Elliot Lee 2002-10-16 13:54:34 EDT
logwatch-4.0 has this

Note You need to log in before you can comment on or make changes to this bug.