Bug 688113 - JON 2.4.1: NPE in Request.removeAttribute()
JON 2.4.1: NPE in Request.removeAttribute()
Status: CLOSED WONTFIX
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
3.0.0
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: ---
Assigned To: nobody nobody
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-16 07:28 EDT by Ondřej Žižka
Modified: 2013-12-07 09:51 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-07 09:51:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ondřej Žižka 2011-03-16 07:28:44 EDT
After uploading a file to the war resource (not sure what it actually did because the application did not appear), I clicked on the "Tomcat Web Application (WAR)" node, and the following exception appeared in a classical catalina error page.
Server log contained only the same stacktrace.
Not easily reproducible.

2011-03-14 14:41:41,165 ERROR [org.apache.catalina.core.ContainerBase] Servlet.service() for servlet Faces Servlet threw exception
java.lang.NullPointerException
at org.apache.catalina.connector.Request.removeAttribute(Request.java:1344)
at org.apache.catalina.connector.RequestFacade.removeAttribute(RequestFacade.java:514)
at javax.servlet.ServletRequestWrapper.removeAttribute(ServletRequestWrapper.java:295)
at com.sun.faces.context.RequestMap.remove(ExternalContextImpl.java:1096)
at org.jboss.seam.contexts.BasicContext.remove(BasicContext.java:73)
at org.jboss.seam.Component.newInstance(Component.java:2167)
at org.jboss.seam.Component.getInstance(Component.java:2024)
at org.jboss.seam.Component.getInstance(Component.java:2003)
at org.jboss.seam.Component.getInstance(Component.java:1997)
at org.jboss.seam.Component.getInstance(Component.java:1970)
at org.jboss.seam.Component.getInstance(Component.java:1965)
at org.jboss.seam.core.Events.instance(Events.java:157)
at org.jboss.seam.core.Events.exists(Events.java:152)
at org.jboss.seam.security.Credentials.getUsername(Credentials.java:53)
at org.jboss.seam.web.LoggingFilter.doFilter(LoggingFilter.java:52)
at org.jboss.seam.servlet.SeamFilter$FilterChainImpl.doFilter(SeamFilter.java:69)
at org.jboss.seam.web.HotDeployFilter.doFilter(HotDeployFilter.java:53)
at org.jboss.seam.servlet.SeamFilter$FilterChainImpl.doFilter(SeamFilter.java:69)
at org.jboss.seam.servlet.SeamFilter.doFilter(SeamFilter.java:158)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
at org.rhq.helpers.rtfilter.filter.RtFilter.doFilter(RtFilter.java:124)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
at org.jboss.web.tomcat.filters.ReplyHeaderFilter.doFilter(ReplyHeaderFilter.java:96)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:230)
at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:173)
at org.jboss.web.tomcat.security.SecurityAssociationValve.invoke(SecurityAssociationValve.java:182)
at org.jboss.web.tomcat.security.JaccContextValve.invoke(JaccContextValve.java:84)
at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:128)
at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:104)
at org.jboss.web.tomcat.service.jca.CachedConnectionValve.invoke(CachedConnectionValve.java:157)
at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:241)
at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:844)
at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:583)
at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:447)
at java.lang.Thread.run(Thread.java:662)
Comment 1 Charles Crouch 2011-03-16 10:59:47 EDT
"After uploading a file to the war resource"

Can you elaborate on what you were doing? Adding war content via the Content tab is not supported. To add a .war you need to create the war resource via its parents Inventory tab.
Comment 2 John 2012-10-16 15:26:06 EDT
Whatever the problem is, it's not related specifically to "adding war content". I have received several identical exceptions - probably caused by refreshing a jfreeplot chart (xmlns:chart="http://sourceforge.net/projects/jsf-comp"). The chart always displays correctly the first time, but when an action requires it to refresh sometimes it results in the following exception. 

I'm not using RHQ, I'm using SEAM (jboss-seam-2.2.2.Final) on apache-tomcat-7.0.29.

java.lang.NullPointerException
	at org.apache.catalina.connector.Request.notifyAttributeRemoved(Request.java:1593)
	at org.apache.catalina.connector.Request.removeAttribute(Request.java:1474)
	at org.apache.catalina.connector.RequestFacade.removeAttribute(RequestFacade.java:554)
	at javax.servlet.ServletRequestWrapper.removeAttribute(ServletRequestWrapper.java:248)
	at com.sun.faces.context.RequestMap.remove(ExternalContextImpl.java:1096)
	at org.jboss.seam.contexts.BasicContext.remove(BasicContext.java:73)
	at org.jboss.seam.Component.newInstance(Component.java:2167)
	at org.jboss.seam.Component.getInstance(Component.java:2024)
	at org.jboss.seam.Component.getInstance(Component.java:2003)
	at org.jboss.seam.Component.getInstance(Component.java:1997)
	at org.jboss.seam.Component.getInstance(Component.java:1970)
	at org.jboss.seam.Component.getInstance(Component.java:1965)
	at org.jboss.seam.core.Events.instance(Events.java:157)
	at org.jboss.seam.core.Events.exists(Events.java:152)
	at org.jboss.seam.security.Credentials.getUsername(Credentials.java:53)
	at org.jboss.seam.web.LoggingFilter.doFilter(LoggingFilter.java:52)
	at org.jboss.seam.servlet.SeamFilter$FilterChainImpl.doFilter(SeamFilter.java:69)
	at org.jboss.seam.web.HotDeployFilter.doFilter(HotDeployFilter.java:53)
	at org.jboss.seam.servlet.SeamFilter$FilterChainImpl.doFilter(SeamFilter.java:69)
	at org.jboss.seam.servlet.SeamFilter.doFilter(SeamFilter.java:158)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:243)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:210)
	at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:225)
	at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:123)
	at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:472)
	at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:168)
	at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:98)
	at org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:927)
	at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:118)
	at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:407)
	at org.apache.coyote.http11.AbstractHttp11Processor.process(AbstractHttp11Processor.java:1001)
	at org.apache.coyote.AbstractProtocol$AbstractConnectionHandler.process(AbstractProtocol.java:585)
	at org.apache.tomcat.util.net.JIoEndpoint$SocketProcessor.run(JIoEndpoint.java:312)
	at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
	at java.lang.Thread.run(Thread.java:662)
Comment 3 Heiko W. Rupp 2013-12-07 09:51:20 EST
Outdated.

Note You need to log in before you can comment on or make changes to this bug.