Bug 688184 - Fix Windows network device naming to use non-ethX names
Fix Windows network device naming to use non-ethX names
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: sigar (Show other bugs)
6.0
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Adam Stokes
: Rebase
Depends On:
Blocks: 688203
  Show dependency treegraph
 
Reported: 2011-03-16 10:38 EDT by Perry Myers
Modified: 2011-12-06 06:45 EST (History)
4 users (show)

See Also:
Fixed In Version: sigar-1.6.5-0.5.git58097d9.el6
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
The sigar package has been upgraded to upstream version 1.6.5, which updates sigar to use Windows device names instead of ethX names. This update also adds a number of bug fixes and enhancements over the previous version.
Story Points: ---
Clone Of:
: 688203 (view as bug list)
Environment:
Last Closed: 2011-12-06 06:45:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Perry Myers 2011-03-16 10:38:12 EDT
Description of problem:
sigar attempts to dynamically map real Windows device names to ethX names, but this naming is useless since Windows has no notion of ethX.  Change sigar to use the Windows device names instead.
Comment 4 Dave Johnson 2011-09-21 09:27:23 EDT
This is good to go in v1.6.5-0.7

qmf: call 1 list
Output Parameters:
    Name       Value
    ==================================================================================================================================================================================================================================================================================================================================================================================================================================================================
    iface_map  ['Loopback Pseudo-Interface 1', 'WAN Miniport (IPv6)-QoS Packet Scheduler-0000', 'WAN Miniport (IP)-QoS Packet Scheduler-0000', 'Loopback Pseudo-Interface 1', 'Local Area Connection', 'WAN Miniport (Network Monitor)-QoS Packet Scheduler-0000', 'Realtek RTL8139C+ Fast Ethernet NIC-WFP LightWeight Filter-0000', 'Realtek RTL8139C+ Fast Ethernet NIC-QoS Packet Scheduler-0000', 'Loopback Pseudo-Interface 1', 'Loopback Pseudo-Interface 1']
Comment 5 Eliska Slobodova 2011-10-26 11:32:36 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
The sigar package has been upgraded to upstream version 1.6.5, which updates sigar to use Windows device names instead of ethX names. This update also adds a number of bug fixes and enhancements over the previous version.
Comment 6 errata-xmlrpc 2011-12-06 06:45:40 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1570.html

Note You need to log in before you can comment on or make changes to this bug.