Bug 68840 - kernel-source make menuconfig & xconfig broken
Summary: kernel-source make menuconfig & xconfig broken
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: kernel (Show other bugs)
(Show other bugs)
Version: limbo
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
: 68936 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-07-15 01:19 UTC by mark krischer
Modified: 2007-04-18 16:44 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-13 09:46:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description mark krischer 2002-07-15 01:19:02 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3; Linux)

Description of problem:
using kernel-source-2.4.18-5.58 and 5.64 from rawhide, make menuconfig and make xconfig do not allow you to save and exit.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. from the console type "make menuconfig"
2. or, in an xterm type "make xconfig"
3.
	

Actual Results:  both menuconfig and xconfig work fine up until "save and exit".  with menuconfig, it never exits.  with xconfig i get the error: 'Error: can't read "CONSTANT_M": no such variable.'

Additional info:

stack trace from xconfig:

can't read "CONSTANT_M": no such variable
    while executing
"list $CONFIG_PCI $CONSTANT_M"
    (procedure "writeconfig" line 310)
    invoked from within
"writeconfig .config include/linux/autoconf.h"
    invoked from within
".f0.right.save invoke"
    ("uplevel" body line 1)
    invoked from within
"uplevel #0 [list $w invoke]"
    (procedure "tkButtonUp" line 7)
    invoked from within
"tkButtonUp .f0.right.save
"
    (command bound to event)

Comment 1 Bill Nottingham 2002-07-17 03:10:58 UTC
*** Bug 68936 has been marked as a duplicate of this bug. ***

Comment 2 Miloš Komarčević 2002-08-08 12:04:34 UTC
I had the same problem, but it seems to be gone in kernel-source-2.4.18-7.93.
It won't compile though, but that's a different problem...

Comment 3 Arjan van de Ven 2002-08-13 09:46:18 UTC
both should be fixed for the next build

Comment 4 Jay Turner 2002-08-16 03:46:27 UTC
Fix confirmed for kernel-source-2.4.18-11.


Note You need to log in before you can comment on or make changes to this bug.