Bug 68842 - /etc/logrotate.d/named uses wrong path to pid file
Summary: /etc/logrotate.d/named uses wrong path to pid file
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: bind   
(Show other bugs)
Version: 7.3
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: wdovlrrw
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-07-15 01:41 UTC by Jordan Russell
Modified: 2007-04-18 16:44 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-15 01:41:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jordan Russell 2002-07-15 01:41:03 UTC
Description of Problem:

Inside /etc/logrotate.d/named you will see:

  /bin/kill -HUP `cat /var/run/named.pid 2> /dev/null` 2> /dev/null || true

This is wrong; /var/run/named.pid does not exist! It should 
be /var/run/named/named.pid.

Because of this error, all logging for named ceases when logrotate runs.


Version-Release number of selected component (if applicable):

bind-9.2.1-0.7x.i386.rpm
and also bind-9.2.1-5 in rawhide


Note You need to log in before you can comment on or make changes to this bug.