Bug 688505 - [zh_CN][CLI]Translation of "subscription-manager register --type"
[zh_CN][CLI]Translation of "subscription-manager register --type"
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.1
Unspecified Unspecified
high Severity medium
: rc
: ---
Assigned To: Bryan Kearney
John Sefler
: Translation
Depends On:
Blocks: rhsm-rhel62
  Show dependency treegraph
 
Reported: 2011-03-17 05:14 EDT by tichen
Modified: 2011-12-06 12:13 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
No description necessary.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 12:13:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Attaching the proper attachment (90.59 KB, image/png)
2011-10-11 08:56 EDT, Shwetha Kallesh
no flags Details

  None (edit)
Description tichen 2011-03-17 05:14:40 EDT
Description of problem:

The output prompt information isn't localized.
Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Unregistered system
2.On command line,run #subscription-manager register --type=system
3.Input valid Username,passwork,then click Enter.
4.On command line,run #subscription-manager register --type=[invaild_type]
  
Actual results:
1.The "Username" and "password" is not translated.
2.The warning message"No such consumer type: invaild_type" is not translated.

Expected results:


Additional info:
Comment 2 tichen 2011-03-17 05:35:47 EDT
Version-Release number of selected component (if applicable):
subscription-manager-debuginfo-0.95.4-1.el6.x86_64
subscription-manager-gnome-0.95.4-1.el6.x86_64
subscription-manager-0.95.4-1.el6.x86_64
subscription-manager-firstboot-0.95.4-1.el6.x86_64
Comment 3 Bryan Kearney 2011-03-17 20:30:25 EDT
Jordan, have the strings been deployed to Candlepin in IT?
Comment 4 RHEL Product and Program Management 2011-04-03 22:04:26 EDT
Since RHEL 6.1 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 6 RHEL Product and Program Management 2011-04-04 08:33:30 EDT
Since RHEL 6.1 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 7 Bryan Kearney 2011-04-05 15:35:06 EDT
this is fixed in the latest susbcription manager (0.96.6). PLease verify it there.
Comment 8 Jin Zhao 2011-04-06 22:46:36 EDT
Verify version:0.95.6-1
Steps:
# LANG=zh_TW subscription-manager register --type=abc
使用者名稱:rhsm_2
密碼:
No such consumer type: abc
Expected results:"No such consumer type: abc" should be translated.
Verify result: zh_TW FAILED.
Comment 9 Jin Zhao 2011-04-06 23:31:36 EDT
Sorry. will verify again after 0.96.6 release.
Comment 12 Shwetha Kallesh 2011-10-07 06:13:51 EDT
Moving the bug to verified

RPM's used:

subscription-manager-gnome-0.97.1-1.git.79.87751d4.el6.x86_64
subscription-manager-0.97.1-1.git.79.87751d4.el6.x86_64
subscription-manager-firstboot-0.97.1-1.git.79.87751d4.el6.x86_64
Comment 13 John Sefler 2011-10-07 08:12:25 EDT
Moving back to ON_QA for verification against latest subscription-manager-0.96 package build for RHEL62.  Please include evidence of test verification.
Comment 14 Shwetha Kallesh 2011-10-11 08:56:59 EDT
Created attachment 527436 [details]
Attaching the proper attachment
Comment 15 Shwetha Kallesh 2011-10-12 06:12:43 EDT
Moving the bug to verified.

[root@dhcp193-9 pki]# LANG=zh_TW subscription-manager register --type=abc --org=admin
警告

這台系統已經透過 RHN Classic 技術,向 RHN 註冊過了。

您正在使用的工具試圖使用 RHN 以認證為主的技術重新註冊。除了少數情況外,Red Hat 建議您只向 RHN 註冊一次。 

欲知更多關於 RHN 註冊與其技術,請參閱知識庫文章:https://access.redhat.com/kb/docs/DOC-45563

使用者名稱:admin
密碼:
沒有此種使用者類型:abc

RPM's used:
[root@dhcp193-9 pki]# rpm -qa | grep subscription-manager
subscription-manager-firstboot-0.96.13-1.el6.x86_64
subscription-manager-gnome-0.96.13-1.el6.x86_64
subscription-manager-0.96.13-1.el6.x86_64
Comment 16 Bryan Kearney 2011-11-14 12:44:09 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No description necessary.
Comment 17 errata-xmlrpc 2011-12-06 12:13:18 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1695.html

Note You need to log in before you can comment on or make changes to this bug.