Bug 68859 - various printing problems: A4, landscape, headers, footers, unix.js
various printing problems: A4, landscape, headers, footers, unix.js
Status: CLOSED CANTFIX
Product: Red Hat Linux
Classification: Retired
Component: mozilla (Show other bugs)
7.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-15 07:01 EDT by Denice
Modified: 2007-04-18 12:44 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 12:51:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
example unix.js config file in /usr/lib/mozilla*/defaults/pref/ (15.23 KB, text/plain)
2002-07-15 07:13 EDT, Denice
no flags Details

  None (edit)
Description Denice 2002-07-15 07:01:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1a) Gecko/20020702

Description of problem:
Printing is a bit of a nightmare with Mozilla.  I have tried every version of
mozilla for which redhat RPMs were built, and there are many problems.  Here I
am mainly reporting on mozilla-0.9.9-12.7.2

 - mozilla reverts to US letter every time, even though I select
    A4 printing.  I have not found the correct value to set in 
    /usr/lib/mozilla*/defaults/pref/unix.js that works across
    versions of mozilla.
  - Landscape printing does not work every time with this version
    of mozilla.  For the 1.0 release candidates and 1.0 and 1.1a from
    mozilla.org landscape printing has completely stopped working.
  - The headers (URLs and title) and footers (page # and date) do
    not appear on the printout with this version; but they do with
    later versions -- but once again landscape printing does not 
    work on those later versions.
  - I support 7 printers and at least 15 print queues.  There is no
    documented way to install on my workstations the knowledge of
    these print queues so that all my users can see them from 
    mozilla.  With this version of mozilla I can get the list to
    appear in the pull-down list, but any print job always goes
    to the printer associated with the PRINTER variable.  With
    version 1.0 I can get print jobs to go the correct printer, but
    then landscape printing no longer works.  I have attached a 
    sample unix.js file.
  - Upgrading RPMs always nukes 
      /usr/lib/mozilla*/defaults/pref/unix.js
    It would be better to either preserve it, or rename and issue a
    warning.

All of this would not bother me so much if I thought that some 
solution was in site.  However mozilla.org seems to be pushing Xprint
as a solution.  Indeed, when one searches in their bugzilla database
for current printing bugs in the linux world, one finds a long
list, and there is a note that many of these bugs do not exist if
you use Xprint. I, like many other redhat admins, will not want to
install something that is not supported by Red Hat.  So I am asking
myself these days if mozilla printing problems with Red Hat's
mozilla RPMs are here to stay.  If they are, then I cannot migrate
my users away from netscape.  The printing problems are just too 
numerous and annoying with mozilla.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. change the page setup to A4 and print. 
2. Quit mozilla and start again, trying to print as above.

	

Additional info:
Comment 1 Denice 2002-07-15 07:13:43 EDT
Created attachment 65345 [details]
example unix.js config file in /usr/lib/mozilla*/defaults/pref/
Comment 2 Christopher Blizzard 2002-07-15 12:43:20 EDT
Printing in Mozilla is kind of screwed up right now, yeah. It's not great but it
has gotten a little better.

mozilla.org is not pushing xprint as a solution, btw.  We would much rather see
the postscript issues fixed.
Comment 3 Bill Nottingham 2006-08-07 15:32:42 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
Please check if this issue is still present in a current Fedora Core
release. If so, please change the product and version to match, and
check the box indicating that the requested information has been
provided. Note that any bug still open against Red Hat Linux on will be
closed as 'CANTFIX' on September 30, 2006. Thanks again for your help.
Comment 4 Bill Nottingham 2006-10-18 12:51:14 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.