Bug 68870 - getca not working
getca not working
Status: CLOSED ERRATA
Product: Stronghold 4.0 for Red Hat Advanced Server
Classification: Retired
Component: crypto-utils (Show other bugs)
2.1AS
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
Stronghold Engineering List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-15 11:29 EDT by Need Real Name
Modified: 2007-04-18 12:44 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-11-07 12:42:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-07-15 11:29:50 EDT
Description of Problem:
getca hostname not working. It returns error: "/usr/bin/getca: cd: 
%SERVERROOT%/conf/ssl/certs: No such file or directory". %SERVERROOT%b is not 
set.

Version-Release number of selected component (if applicable):
Stronghold 4

How Reproducible:
Always

Steps to Reproduce:
1. install SH4 for AS
2. use getca
3. 

Actual Results:
Error message As above

Expected Results:


Additional Information:
Comment 1 Joe Orton 2002-07-15 12:15:29 EDT
The getca problem is due to the openssl configuration file expecting more fields
than are being provided by genkey.  /usr/bin/genreq and getcert and others also
have incorrect % expansions.
Comment 2 Need Real Name 2002-08-13 04:39:03 EDT
Change this bug to be for Stronghold 4.0 for Red Hat Advance Server instead of
Stronghold for Red Hat Linux.
Comment 3 Joe Orton 2002-11-07 12:42:22 EST
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2002-168.html

Note You need to log in before you can comment on or make changes to this bug.