Bug 688780 - SoundConverter does not open on my system F-LXDE 13
Summary: SoundConverter does not open on my system F-LXDE 13
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: soundconverter
Version: 13
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Michael Schwendt
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-03-18 00:28 UTC by nomnex
Modified: 2011-04-02 22:51 UTC (History)
2 users (show)

Fixed In Version: soundconverter-1.5.3-8.fc13
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-04-02 22:51:46 UTC


Attachments (Terms of Use)

Description nomnex 2011-03-18 00:28:42 UTC
Description of problem:

I have installed SoundConverter (Gnome) from the Fedora repo. Installation went fine. Error message on launch

Version-Release number of selected component (if applicable):

SoundConverter 1.5.3

How reproducible:

Always

Steps to Reproduce:
1. Alt+F2 "Soundconverter"
2.
3.
  
Actual results:

error msg

[user@machine flashgot]$ soundconverter
SoundConverter 1.5.3
ImportError: could not import bonobo.ui
  using Gstreamer version: 0.10.30
  using gio
	'faac' gstreamer element not found, disabling AAC.
  using 1 thread(s)

(soundconverter:5011): libglade-WARNING **: unknown widget class 'GnomeAbout'
/usr/bin/soundconverter:2800: GtkWarning: GtkSpinButton: setting an adjustment with non-zero page size is deprecated
  glade = gtk.glade.XML(GLADE)
Traceback (most recent call last):
  File "/usr/bin/soundconverter", line 2906, in <module>
    main(args)
  File "/usr/bin/soundconverter", line 2898, in main
    gui_main(args)
  File "/usr/bin/soundconverter", line 2801, in gui_main
    win = SoundConverterWindow(glade)
  File "/usr/bin/soundconverter", line 2528, in __init__
    self.about.set_property('version', VERSION)
TypeError: object of type `GtkLabel' does not have property `version'
[user@machine flashgot]$

Comment 1 Michael Schwendt 2011-03-18 08:23:37 UTC
If you install "gnome-python2-bonobo", does that fix it?

Comment 2 nomnex 2011-03-20 11:51:29 UTC
yes, it did it thanks. Does it apply to F-14 LXDE too?

Comment 3 Michael Schwendt 2011-03-22 15:12:34 UTC
It's due to a dropped dependency in gnome-python2-gnome when it was created as a new subpackage in 2008. See bug 689836 - easy to work around in "soundconverter", but I'd like to learn why that dependency is missing.

Comment 4 Fedora Update System 2011-03-23 20:21:51 UTC
soundconverter-1.5.3-8.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/soundconverter-1.5.3-8.fc13

Comment 5 Fedora Update System 2011-04-02 22:51:40 UTC
soundconverter-1.5.3-8.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.