Bug 68879 - Adding acct scrambles rootpassword
Adding acct scrambles rootpassword
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: kdeadmin (Show other bugs)
limbo
i386 Linux
medium Severity high
: ---
: ---
Assigned To: wdovlrrw
Mike McLean
:
: 72503 (view as bug list)
Depends On:
Blocks: 67217
  Show dependency treegraph
 
Reported: 2002-07-15 12:44 EDT by Chuck Forsberg
Modified: 2007-04-18 12:44 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-29 21:44:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chuck Forsberg 2002-07-15 12:44:02 EDT
Description of Problem:  Adding a user account with KDE user mgr scrambles 
root password.


Version-Release number of selected component (if applicable):
7.3.92

How Reproducible:


Steps to Reproduce:
1. Add a user account/password.
2. login (root)
3. 

Actual Results:


Expected Results:


Additional Information:
	
Workaround - use passwd to restore roots' password after adding user acct

Gnome user mgr did not allow setting group on user acct
Comment 1 Bill Nottingham 2002-07-16 22:18:11 EDT
Havoc: what's the policy on shipping GUI config tools that configure the same
things as our tools?
Comment 2 Havoc Pennington 2002-07-16 23:28:30 EDT
Duplicate config tools should not be in the menus or the control center. i.e.
totally invisible from the GUI. It's fine if they are in /usr/bin/.
Comment 3 Nalin Dahyabhai 2002-07-23 15:11:39 EDT
The kuser account manager is in the kdeadmin package.
Comment 4 Havoc Pennington 2002-08-21 13:01:46 EDT
Ah this never got reassigned to the right person.

KDE user tool should be deleted, please close this bug once it's gone.
Comment 5 Bernhard Rosenkraenzer 2002-08-22 11:00:07 EDT
Fixed in 3.0.3-3
Comment 6 Jay Turner 2002-08-29 21:44:51 EDT
OK, did we decide not to delete the application?

[haring (jkt):/mnt/redhat/beehive/comps/dist/8.0/kdeadmin/3.0.3-3/i386]$ rpm
-qpl kdeadmin-3.0.3-3.i386.rpm | grep kuser
warning: kdeadmin-3.0.3-3.i386.rpm: Header V3 DSA signature: NOKEY, key ID 897da07a
/etc/pam.d/kuser
/etc/security/console.apps/kuser
/usr/bin/kuser
/usr/sbin/kuser
Comment 7 Jay Turner 2002-08-29 21:54:46 EDT
OK, ignore me, I'm an idiot.  Thought we were removing the binary, but I now
realize we are just removing the link from GUI, which is indeed done with
kdeadmin-3.0.3-3.
Comment 8 Bill Nottingham 2002-09-25 16:08:11 EDT
*** Bug 72503 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.