This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 68891 - imap logins do not work with the pam_mkhomedir PAM module.
imap logins do not work with the pam_mkhomedir PAM module.
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: imap (Show other bugs)
7.2
All Linux
medium Severity low
: ---
: ---
Assigned To: John Dennis
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-15 15:38 EDT by Russell Jungwirth
Modified: 2007-04-18 12:44 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-10 15:15:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Russell Jungwirth 2002-07-15 15:38:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.0) Gecko/20020529

Description of problem:
UW imap doesn't call pam_open_session and pam_close_session in the current linux
versions because of an incompatibility with certain pam implementations on other
unices.  pam_mkhomedir requires a session to be opened to trigger its work. 
This problem shows up when an account is authenticated, but does not have an
existing home directory, such as when authenticating against a windows domain
using pam_winbind.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. place this line in /etc/pam.d/imap  :
session    required     /lib/security/pam_mkhomedir.so skel=/etc/skel/ umask=0027
2.  create a new account.  remove it's home directory.
3.  login via imap using the account above. 


Actual Results:  The home directory for the new account doesn't get created.

Expected Results:  The home directory for the new account should be created
automatically.

Additional info:

I have fixed this bug.  See the modified source code at
http://chumpsquad.com/bugfixes/ckp_pam.c  The file it replaces is
imap-2000c/src/osdep/unix/ckp_pam.c  I simply added calls to pam_open_session
and pam_close_session.  This change should be added as an additional patch to
the RPM.   For corroborating evidence of this bug, see
http://archives.neohapsis.com/archives/pam-list/2002-01/0095.html
Comment 1 Mike A. Harris 2002-07-16 05:47:30 EDT
You're referencing imap-2000c, however the current version of the imap
package that we ship and support, is 2001a, which is available as an update
via Red Hat Network (up2date) or via our ftp site.  Please upgrade
to the latest version of imap that we have available for Red Hat Linux
7.2, and update the bug report with your results.

After you're using the latest version, if the problem persists, I can
investigate the issue.  There isn't sense in me wasting time however on
an ancient release of the software.
Comment 2 Russell Jungwirth 2002-07-16 09:29:57 EDT
I have verified that the same bug appears in the new version of imap from 
ftp://updates.redhat.com/7.2/en/os/SRPMS/imap-2001a-1.72.0.src.rpm and of 
course the regular RPM as well.  The code for ckp_pam.c in the new version has 
commented code that recognizes the error documented above.  I've made the 
changes to the code and recompiled and verified that the problem is fixed.  The 
updated code is located at the same url as above 
http://chumpsquad.com/bugfixes/ckp_pam.c
Comment 3 Mike McLean 2003-01-02 14:03:06 EST
This bug has been inappropriately marked MODIFIED. Please review the bug life
cycle information at 
http://bugzilla.redhat.com/bugzilla/bug_status.cgi

Changing bug status to ASSIGNED.
Comment 4 Mike McLean 2004-06-10 15:03:51 EDT
Did this fix ever make it in?
Comment 5 John Dennis 2004-06-10 15:15:29 EDT
I don't know anything about this bug however 7.2 is rather old and we
no longer ship UW imap. I'm closing as won't fix.

Note You need to log in before you can comment on or make changes to this bug.