Bug 688993 - Make comparisons to None (singleton) done with 'is' and 'is not'
Make comparisons to None (singleton) done with 'is' and 'is not'
Status: CLOSED DEFERRED
Product: Virtualization Tools
Classification: Community
Component: virtinst (Show other bugs)
unspecified
All Linux
unspecified Severity low
: ---
: ---
Assigned To: Cole Robinson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-18 14:22 EDT by Satoru SATOH
Modified: 2012-01-24 20:35 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-24 20:35:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Satoru SATOH 2011-03-18 14:22:33 EDT
Description of problem: This is a trivial patch to make comparisons to
None done with 'is'/'is not' instead of '=='/'!=' on the advice in
pep8 (http://www.python.org/dev/peps/pep-0008/):

   - Comparisons to singletons like None should always be done with
     'is' or 'is not', never the equality operators.

Version-Release number of selected component (if applicable):
I made a pathc for git HEAD but I guess it should be applicable to 
the versions of python-virtinst in fedora-14/15.
Comment 1 Cole Robinson 2011-03-21 11:53:35 EDT
Moved to upstream virtinst tracker. I'd be interested in seeing the patch
Comment 2 Cole Robinson 2012-01-24 20:35:43 EST
Closing since no patch provided and not really something that needs tracking in bugzilla.

Note You need to log in before you can comment on or make changes to this bug.