Bug 68914 - "mpage -2H xxx.ps | lpr" doesn't go landscape
"mpage -2H xxx.ps | lpr" doesn't go landscape
Product: Red Hat Linux
Classification: Retired
Component: cups (Show other bugs)
i386 Linux
high Severity high
: ---
: ---
Assigned To: Tim Waugh
: 76419 76427 76857 78721 78746 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2002-07-15 17:57 EDT by Horst H. von Brand
Modified: 2008-05-01 11:38 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2003-01-22 05:39:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Horst H. von Brand 2002-07-15 17:57:58 EDT
Description of Problem:
Printing side-by-side using mpage -2H prints the 2 pages in portrait, not landscape.
cups enabled, printer is a HP Laserjet 4000 connected to the network.
ghostscript shows the file fine

Version-Release number of selected component (if applicable):

How Reproducible:

Steps to Reproduce:
1. mpage -2H xxx.ps > xxx-2.ps
2. lpr xxx-2.ps

Actual Results:
Pages are printed in portrait (doesn fit paper, obviously), not landscape

Expected Results:
Landscape printing.

Additional Information:
Comment 1 Tim Waugh 2002-10-07 07:48:22 EDT
I've seen this too.
Comment 2 Carlos Rodrigues 2002-10-11 19:06:30 EDT
I'm seeing this with RedHat 8.0 also. Every landscape postscript file I throw at
cups gets printed in portrait. My printer is an Epson Stylus Color 880
CUPS+gimp-print driver.
Comment 3 H.Breimer 2002-10-12 08:48:56 EDT
Just installed box 8.0. Same problem. Workaround?
Comment 4 Carlos Rodrigues 2002-10-18 16:02:55 EDT
I've tried everytinh I remember (with all the available printer drivers etc.) to
no avail. This is really bad...
Comment 5 Carlos Rodrigues 2002-10-19 10:51:00 EDT
Picked up the cups SRPM from cd5 and replaced the 1.1.15 tarball with 1.1.16 and
it is working now (can print landscape again).
Comment 6 Tim Waugh 2002-10-21 11:57:58 EDT
*** Bug 76419 has been marked as a duplicate of this bug. ***
Comment 7 Tim Waugh 2002-10-22 04:25:43 EDT
*** Bug 76427 has been marked as a duplicate of this bug. ***
Comment 8 André Johansen 2002-10-23 03:19:54 EDT
I have a box upgraded from Red Hat 7.3/CUPS, and I see the same problem; it 
was able to print landscape before the upgrade, but not afterwards. 
I'll try the upgrade to 1.1.16. 
Comment 9 Tim Waugh 2002-10-23 04:28:57 EDT
You probably want to wait for 1.1.17, due out any day now.
Comment 10 giulioo 2002-10-30 04:33:44 EST
*** Bug 76857 has been marked as a duplicate of this bug. ***
Comment 11 Lars Munch 2002-11-07 03:14:44 EST
A fix for this bug can be found here:
I have applied this to the cups source rpm, and I got landscape printing again.

I have uploaded some RPMs on http://lwb1.it.dtu.dk/~lmc/rpms/ for those who can
wait for redhat 8.1 :-)
Comment 12 Tim Waugh 2002-11-28 06:07:36 EST
*** Bug 78721 has been marked as a duplicate of this bug. ***
Comment 13 Tim Waugh 2002-11-28 12:55:42 EST
*** Bug 78746 has been marked as a duplicate of this bug. ***
Comment 14 Need Real Name 2002-12-04 15:18:10 EST
Grabbing cups-1.1.16-1.i386.rpm from the RawHide 1.0 distribution on rpmfind.net
fixed it for me.
Comment 15 Jos Vos 2002-12-05 11:34:06 EST
Will an errata package be release for RH 8.0?  It is a pretty serious problem in
some office environments...
Comment 16 Tim Waugh 2002-12-05 11:36:01 EST
I'd like to wait for at least 1.1.17 before issuing any advisory.  I'll keep
this open as a reminder.
Comment 17 André Johansen 2003-01-22 05:32:49 EST
This seems to have been fixed with the recent cups-1.1.17-0.2 release; 
I'm able to print in landscape mode through KDE now. 

Note You need to log in before you can comment on or make changes to this bug.